
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Perinatal Problem Identification Program 
 
 

Version 2.1 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Copyright © Simply Software 



The Perinatal Problem Identification Program v2.1 
 
 

 
 
2 



The Perinatal Problem Identification Program v2.1 
 
 

 

INTRODUCTION TO PPIP V2 8 

PERINATAL PROBLEM IDENTIFICATION PROGRAM - WHAT'S IT ALL ABOUT? 8 
AUDIT SUPPORT PROVIDED BY PPIP 8 
MANAGING DIFFERENT LEVELS OF HEALTH CARE PROVIDERS 8 
DATA ANALYSIS 9 
PROGRAM ADMINISTRATION 9 

UPGRADING FROM PPIP V1 10 

WHAT'S NEW IN PPIP V2? 11 

DATA SETS 13 

SOME PRINCIPLES 13 
SETTING UP A DATA SET 13 
EDIT DATA SET DETAIL 14 
DATA SET DETAIL - ENTRY FIELDS 14 
DELETE DATA SET 15 
OPEN A DATA SET 15 

DATA PYRAMID EXPLAINED 17 

WHAT HAPPENS IN THE REAL WORLD? 17 
HOW DOES PPIP IMPLEMENT THIS SYSTEM? 17 
VIEWING YOUR DATA PYRAMID 18 

THE THREE DATA TYPES 19 

PERINATAL DEATHS ENTERED WITH MONTHLY DATA 20 

WHY ENTER PERINATAL DEATHS TWICE? 20 
THREE WAYS TO USE PPIP 20 

ENTERING MONTHLY DATA 22 

ADD MONTHLY DATA 22 
EDIT MONTHLY DATA 22 
MONTHLY DATA ENTRY FIELDS 22 
DELETE MONTHLY DATA 24 

PERINATAL DEATHS 25 
 
 
3 



The Perinatal Problem Identification Program v2.1 
 
 

ADD A PERINATAL DEATH 25 
EDIT A PERINATAL DEATH 25 
PERINATAL DEATH ENTRY FIELDS 25 
PERINATAL DEATH CODES 28 
PRIMARY CAUSE OF PERINATAL DEATH 28 
FINAL CAUSE OF NEONATAL DEATH 28 
AVOIDABLE FACTOR 29 
WHAT ARE AVOIDABLE FACTORS? 29 
AVOIDABLE FACTOR GRADING 29 
DELETE A PERINATAL DEATH 29 

MATERNAL DEATH 31 

ADD A MATERNAL DEATH 31 
EDIT A MATERNAL DEATH 31 
MATERNAL DEATH ENTRY FIELDS 31 
MATERNAL DEATH CODES 33 
OBSTETRIC CAUSE OF MATERNAL DEATH 33 
FINAL CAUSE OF MATERNAL DEATH 33 
DELETE A MATERNAL DEATH 33 

DATA ANALYSIS PRINCIPLES 34 

HOW TO GET TO THE DATA ANALYSIS FUNCTIONS 34 

DEFAULT DATA ANALYSIS SETTINGS 36 

DEFAULT DATES 36 
DEFAULT DATA CALCULATION METHOD 36 

DATA ANALYSIS 37 

TOTAL DELIVERIES 37 
DEFINE REPORT - TOTAL DELIVERIES 38 
DELIVERIES PER MONTH 39 
COMPARE UNITS 40 
UNPROCESSED MONTHLY DATA 41 
FETAL, PERINATAL & NEONATAL MORTALITY RATES 42 
DEFINE REPORT - FETAL, PERINATAL & NEONATAL MORTALITY RATES 44 
INFORMATION ON CALCULATION OF RATES & RATIOS 44 
MONTHLY PERINATAL MORTALITY RATE 44 
PRIMARY CAUSE OF PERINATAL DEATH 46 
PRIMARY CAUSE OF PERINATAL DEATH – DATA FILTER 47 
FINAL CAUSE OF NEONATAL DEATH 50 
FINAL CAUSES OF NEONATAL DEATH – DATA FILTER 51 
UNPROCESSED PERINATAL DEATH DATA 54 

 
 
4 



The Perinatal Problem Identification Program v2.1 
 
 

LIST AVOIDABLE FACTORS 55 
LIST AVOIDABLE FACTORS – DATA FILTER 56 
MONTHLY AVOIDABLE MORTALITY RATE 59 
MONTHLY AVOIDABLE PERCENTAGE 60 
PRIMARY CAUSE OF MATERNAL DEATH 62 
FINAL CAUSE OF MATERNAL DEATH 64 
MATERNAL MORTALITY RATE & RATIOS 66 
DEFINE REPORT - MATERNAL MORTALITY RATE & RATIOS 67 
INFORMATION ON CALCULATION OF RATES & RATIOS 67 
UNPROCESSED MATERNAL DEATH DATA 67 
MODE OF DELIVERY 68 
OTHER MISCELLANEOUS DATA 70 
PREDEFINED MONTHLY REPORT 72 

DATA TRANSFER 73 

IMPORT PPIP V1 DATA 73 
IMPORT V1 DATA - INCONSISTENT DATA 75 
IMPORT DATA FILE 75 
IMPORT DATA FILE - DUPLICATE ID 77 
EXPORT DATA FILE 77 

BACKUP ALL DATA 79 

BACKUP GUIDELINES 79 

RESTORE ARCHIVED DATA 81 

DATA VALIDITY CHECK 82 

TOTAL BIRTHS UPDATE WIZARD 83 

PRINT DATA SHEETS 85 

NUMBER OF COPIES 85 

PRINT CODE LISTS 86 

NUMBER OF COPIES 86 

PROGRAM SETTINGS 87 

DATA ENTRY 87 
DATA ANALYSIS 87 

 
 
5 



The Perinatal Problem Identification Program v2.1 
 
 

DATA PRINTOUTS 90 
MONTHLY REPORT 90 

PRINT PREVIEW 92 

REGISTERING PPIP 93 

TELL US ABOUT YOURSELF 93 
WHAT IF I DON'T WANT TO REGISTER? 93 
HOW DO I REGISTER? 93 
ARE THERE ANY RESTRICTIONS? 94 

LICENSING AGREEMENT 95 

CONTACT DETAIL 98 

IDENTIFYING PROGRAM FUNCTIONS 99 

MAIN MENU 99 
DROP-DOWN LIST 99 
CHECK BOX 100 
BUTTON BAR 100 
SPIN BOX 100 
TAB 100 
POP-UP CALENDAR 101 
RADIO BUTTONS 101 

DEFINITIONS 102 

LIVE BIRTH 102 
FETAL DEATH (DEADBORN FETUS) 102 
BIRTH WEIGHT 102 
LOW BIRTH WEIGHT 103 
VERY LOW BIRTH WEIGHT 103 
EXTREMELY LOW BIRTH WEIGHT 103 
PERINATAL PERIOD 103 
NEONATAL PERIOD 103 
FETAL DEATH RATIO 104 
FETAL DEATH RATE 104 
EARLY NEONATAL MORTALITY RATE 104 
PERINATAL MORTALITY RATE 104 
NEONATAL MORTALITY RATE 105 
MATERNAL DEATH 105 
MATERNAL MORTALITY RATE 105 
MATERNAL MORTALITY RATIO 106 
PERINATAL CARE INDEX 106 

 
 
6 



The Perinatal Problem Identification Program v2.1 
 
 

3-MONTH MOVING AVERAGE 106 
OBSTETRIC CAUSE OF PERINATAL DEATH 107 
FINAL CAUSE OF NEONATAL DEATH 107 
OBSTETRIC CAUSE OF MATERNAL DEATH 107 
FINAL CAUSE OF MATERNAL DEATH 107 
 
 

 
 
7 



The Perinatal Problem Identification Program v2.1 
 
 

Introduction to PPIP v2 
 
Perinatal Problem Identification Program - what's it all about? 
 
The Perinatal Problem Identification Program (PPIP) is a tool to make your perinatal and maternal 
death audit easier. It does not do the audit for you, but it takes the tedious paperwork out of the 
process. The moment you enter the basic data, you can instantly do extensive data analysis, and 
even present your data in graphs and print reports - all with the press of a button. 
 
Let there be no doubt: medical audit (and certainly perinatal and maternal death audit) is not a 
process that happens without dedicated individuals spending time and effort to make it happen. 
Furthermore, audit is a futile process if it doesn't 'close the loop' by changing the practice it is 
auditing. The purpose of audit is not the audit, or the figures, or the reports it generates, but the 
improvement of practice. If you do not intend to change the way you care for mothers and their 
babies, you can close this program and delete it from your computer - you will be wasting your 
time. If, on the other hand, you want the quality of your care to be weighed and measured 
because you want to do better, PPIP will provide you with an instrument to make sense of your 
data without spending hours going through data sheets. 
 
Audit support provided by PPIP 
 
Medical audit includes a number of actions. PPIP makes sense of this process by providing you 
with three 'levels' of data entry: 
•  Doing the numbers 
 PPIP allows you to collect numbers of deliveries, stillbirths, early and late neonatal deaths and 
maternal deaths. This allows the calculation of different rates (e.g. a perinatal mortality rate) and 
is used as denominator in various calculations. A selection of 'miscellaneous' data fields allows 
entry and analysis of specific detail, e.g. mode of delivery. 
•  Identifying causes 
 Each perinatal and maternal death is entered in more detail. PPIP allows entry of basic 
demographic data, after which a primary obstetric cause of death and a final cause of death must 
be identified. Obviously these causes can then be analyzed in detail. 
•  Avoidable? 
 Lastly, PPIP allows for the identification of specific avoidable factors. These are incidents related 
to the actions of the mother or health care personnel, or the health care system, which may have 
altered the outcome of the specific case had it been managed differently. Again, these avoidable 
factors can be included in data analysis. 
 
Managing different levels of health care providers 
 
In real life different health care providers work together on different levels to provide relevant 
care. PPIP refers to this structure as a health care pyramid because a broad base of basic health 
care providers will refer to, or be included in the responsibility of, a next level of care providers. 
Every higher level usually includes a progressively larger geographic area. PPIP mirrors this 
structure by allowing the user to create a data pyramid of different 'levels' of units. 
 
When data is entered, it is assigned to a specific unit (care provider). Any data analysis for this 
particular unit will then include this birth/death. When you do any data analysis of a unit higher in 
the data pyramid, you can choose whether you want to include only this unit's data, or all the 
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units below it as well. 
 
PPIP allows the creation of a data pyramid of up to ten levels. 
 
Data analysis 
 
The real strength of PPIP is the fact that it provides a variety of data analysis functions which can 
be fine tuned to look at exactly what you want to. A data analysis menu is provided, on which the 
main groups of data analysis options are provided. Different buttons then provide analysis 
screens with a default analysis. The user can include or exclude birth weight groups, dates, 
causes of death etc. to drill down to the required answer.  
 
The user can also display and print unprocessed data, i.e. basically the complete data file without 
any manipulation of the data. 
 
PPIP also allows most data to be exported to Microsoft Excel for any other data manipulation you 
may require. 
 
Program administration 
 
PPIP allows the following administrative functions: 
•  Import version 1 data 
 A wizard (step-by-step automated administrative process) makes it simple to make the 
necessary changes to the data collected with PPIP version 1 to make it compatible with this new 
version. 
•  Export PPIP data 
 A wizard transfers selected data to a unique transfer file which can then be imported to PPIP by 
another user. 
•  Import PPIP v2 data 
 The data previously exported to a transfer file can be imported, which includes it in the current 
data file. 
•  Backup data 
 A two-step process backs up all your data to a single compressed file in .zip format. 
•  Restore data 
 A previously backed-up file can be restored automatically. 
•  Print data sheets 
 Data collection sheets can be printed. (Monthly births data, perinatal death and maternal death.) 
•  Print code lists 
 Lists displaying the codes for causes of death and avoidable factors can be printed.  
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Upgrading from PPIP v1 
 
PPIP v2 can use all your existing data created with the older version of PPIP, but it has to be 
upgraded (imported) into your new program. Follow these steps to accomplish this: 
 
1. Make a backup of your existing PPIP v1 data. (This includes all the data files with the 
extension .tps found in the program folder and all sub folders created by PPIPv1. Keep these 
backups safe! 
 
2. Open PPIP v2, if it is not already open. 
 
3. Use the Import v1 data wizard to import each data set created with PPIP v1. As you import the 
data, the units in your original data pyramid will become available in the new program. It is a good 
idea to start importing from the top of your existing data pyramid (if you had more than one unit in 
PPIP v1) and then to work your way down. This will allow you to place lower level units in their 
correct place in your new data pyramid. 
 
THAT'S IT! 
 
Now, you may want to read about the most important changes to PPIP - enjoy!  
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What's new in PPIP v2? 
 
PPIP v2 was designed along the same principles as its predecessor - but with some extra's. This 
page will mention items, with links to the detailed descriptions found in this Help file. 
 
Things that stayed the same 
•  You still open one unit's data (called a data set) at a time.  
•  You still enter your data in three parts: Total births during a month, Perinatal deaths, and 
Maternal deaths.  
•  You still have a single menu system to get to all the data analysis functions.  
•  You can still select the dates for which you want to do your data analyses.  
•  PPIP still uses the same code lists (Version 2.01) - the version is displayed in the About 
window.  
•  You can still define preset data analysis dates before opening data analysis screens, to make it 
easier to look at the same data on all data analysis windows.  
•  A context sensitive Help file still explains all the functions. Click on the Help button, or press F1 
on the keyboard, to display relevant help topics.  
•  PPIP is still supplied to you free of charge. 
  
Things that changed 
•  You don't have to worry about where PPIP keeps its data. All data is now written to a single set 
of files, kept on the program folder. So, when you create a new data set, you do not have to 
supply a data folder.  
•  A number of data fields have been added to Total births, Perinatal deaths and Maternal deaths 
entries.  
•  Automated Backup and Restore functions have been added.  
•  PPIP now allows a more basic use, where no detailed Perinatal death detail is entered, but the 
number of stillbirths, perinatal deaths and neonatal deaths are entered with Total monthly data. 
This allows you to calculate certain mortality rates and ratios, but does not allow you to use all 
the data analysis methods. You can also use the death data entered with Total births to do data 
validity checks. See here for a description of data entry options.  
•  All data analysis functions offer more ways to define exactly which data is to be included in the 
analyses.  
•  In addition to perinatal and neonatal mortality rates, this analysis now includes early neonatal 
mortality rate, fetal death ratio and fetal death rate.  
•  Previously only the maternal mortality rate was presented, while this analysis now supplies you 
with the Maternal mortality ratio (using all births and using live births only) and the Maternal 
mortality rate.  
•  PPIP v2 introduces the use of data filters, with which you can include or exclude specific 
subgroups of data when creating lists of causes / factors. Data filters are used in Primary cause 
of perinatal death analysis, Final cause of neonatal death analysis, List avoidable factors 
analysis, Primary cause of maternal death analysis and Final cause of maternal death analysis.  
•  Whenever you are presented with data tables, you can now transfer these data tables to 
Microsoft Excel with a click of a button.  
•  All data printouts are displayed as a report preview before they are printed. You can then 
choose to print only part of the report.  
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•  Monthly data, perinatal death data and maternal death data are also presented unprocessed, 
i.e. you can display a table containing the data file entries without any data manipulation.  
•  If a data set has other data sets below it in the data pyramid, you can now choose to include 
these lower levels when doing the data analyses, or to use only data from the selected data set in 
the data analysis.  
•  A preset monthly report can now be defined and printed.  
•  You now have to register your copy of PPIP with the author, and obtain a licence, to use the 
program.  
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Data sets 
 

Some principles 
 
PPIP refers to the place where data is collected as a Data set. In reality this can be a single 
practitioner, a midwife obstetric unit, a clinic, a hospital.... Data in different data sets can be 
combined during data analysis, but data entered in a specific data set cannot be separated.  
 
Before any data can be entered in PPIP, you have to set up at least one data set. The same 
program can manage an infinite number of data sets, but only one data set can be open at any 
time. 
 
If you want to set up a complete data pyramid, make sure that you have worked out the different 
levels, then set up the different data sets on your computer, starting from the top of the pyramid, 
and work your way down to the lower levels. 
 
You can select a data set to be opened by default when you run PPIP. 
 
Setting up a data set 
 
To set up a new data set, select File -> New data set... from the Main program menu, or press 
Ctrl-N on the keyboard. The New data set window will open. 
 
The following entry fields have to be completed: 
•  Name 
 Enter a name for the new data set. Any alphanumeric characters can be used. A maximum of 35 
characters will be allowed. The name must be unique - you will be prompted for a new name if a 
data set with the name already exists when you save the new data set. 
•  Health district 
 Identify the health district to which this data set belongs. Any alphanumeric characters can be 
used. A maximum of 35 characters will be allowed. 
•  Health region 
 Identify the health region to which this data set belongs. Any alphanumeric characters can be 
used. A maximum of 35 characters will be allowed. 
•  Level of care 
 Select a level of care from the drop-down list which best describes the new data set. The choices 
are:  

•  Rural  
•  Rural, periurban  
•  Periurban  
•  Periurban, urban  
•  Urban  
•  Rural, periurban, Urban 
   

•  Data pyramid 
 If this data set is to be positioned under a higher level in the data pyramid, check the Assign to a 
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higher level check box. If the check box is checked, the Higher level unit drop-down list will be enabled. 
This list displays all the data sets previously created. Select the unit under which you want to 
position the new data set. 
 
Click on the View data pyramid button to view the current data pyramid.  
Click on the OK button to save the new data set, or on the Cancel button to cancel without saving 
the new data set.  
 
 
 
Edit data set detail 
 
 To change a data set previously set up, select File -> Edit data set detail... from the Main 
program menu, or press Ctrl-E on the keyboard. The Select the data set you want to edit 
window will open. This window displays a list of data sets.  
 
Select (Left-click) on the data set you want to edit, then click on the Edit button. The Edit existing 
data set window opens, allowing you to make the necessary changes. 
 
(You can also double-click on the data set to be edited.) 
 
Click on the Close button to close the list of data sets. 
 

 
Data set detail - entry fields 
 
The following entry fields can be changed: 
•  Name 
 You can change the data set's name. Any alphanumeric characters can be used. A maximum of 
35 characters will be allowed. The name must be unique - you will be prompted for a new name if 
a data set with the same name (other than the one you are editing) already exists when you save 
the data set. 
•  Health district 
 Identify the health district to which this data set belongs. Any alphanumeric characters can be 
used. A maximum of 35 characters will be allowed. 
•  Health region 
 Identify the health region to which this data set belongs. Any alphanumeric characters can be 
used. A maximum of 35 characters will be allowed. 
•  Level of care 
 Select a level of care from the drop-down list which best describes the new data set. The choices 
are:  

•  Rural  
•  Rural, periurban  
•  Periurban  
•  Periurban, urban  
•  Urban  
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•  Rural, periurban, Urban 
   

•  Data pyramid 
 If this data set is to be positioned under a higher level in the data pyramid, check the Assign to a 

higher level check box. If the check box is checked, the Higher level unit drop-down list will be enabled. 
This list displays all the other data sets previously created. Select the unit under which you want 
to position the new data set. 
 
Click on the View data pyramid button to view the current data pyramid. Click here for more 
information on setting up a data pyramid. 
 
Click on the OK button to save the changes to the data set, or on the Cancel button to cancel 
without saving the changes you have made.  
 

 
Delete data set 
 
To delete a data set previously set up, select File -> Delete data set from the Main program 
menu. The Select data set to delete window will open. This window displays a list of data sets.  
 
Deleting a data set removes the reference to the data set, and does not necessarily delete the 
data set's data. Before you delete a data set, decide whether you also want to delete the data 
previously entered for this particular data set. If you also want to delete the data, check the Remove 

the data as well check box. If you want to remove the reference to this data set, but you want its data 
to remain on disk, uncheck the Remove the data as well check box. 
 
Select (Left-click) on the data set you want to delete, then click on the Delete button. A warning will 
be displayed to ensure you have selected the correct action. 
 
Click on the Close button to close the list of data sets.  
 

 
Open a data set 
 
PPIP uses only one data set's data at a time. Therefore, before you can enter data or do any data 
analysis, you have to open a data set. 
 
To open a data set, select File -> Open data set... from the Main program menu, click on the 
Open data set button on the button bar, or press Ctrl-O on the keyboard. The Select data set 
window will open.  
 
If you have not selected a data set to open by default, this window will open automatically when 
you run PPIP.  
 
To open a data set, select (Left-click on) the data set you want to open, then click on the Open 

button, or double-click the data set. The data set's files will be opened and the Select data set 
window will close. The name of the newly selected data set is displayed on the program frame. 

 
 

15 



The Perinatal Problem Identification Program v2.1 
 
 

 
If you will be using the same data set every time you open PPIP, you can bypass this step by 
selecting a data set to be opened by default. Select (Left-click on) the data set you want to open 
by default, then check the Open this data set by default check box. Now proceed to open the data set as 
described above. The next time you run PPIP, the selected data set will open without prompting 
you to select a data set. 
 
You can create a new data set by clicking on the New data set button. This will open the New data 
set window to set up the new data set. 
 
Click on the Cancel button to close the window without opening a new data set.  
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Data pyramid explained 
 
What happens in the real world? 
 
Health care systems usually function on different levels. An individual patient may enter this 
system at any level, and may stay at that level or be transferred to a next level. This system could 
be presented as follows: 
 

 
 
How does PPIP implement this system? 
 
PPIP mirrors this tiered system to enable you to look at data on different levels. When data 
collected at different units are all imported to PPIP, in a logical data pyramid, you can analyze 
data for each unit separately and you can perform the same analysis for any level, automatically 
including all the data collected in the units below it in the data pyramid. Take note that the PPIP 
data pyramid will recreate the real-life levels, but may add levels to create a logic data analysis 
system. The real-life situation in the graphic above may therefore be changed to: 
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You are allowed to create up to ten levels in the data pyramid.  
 
 
 
Viewing your data pyramid 
 
To view your current data pyramid, select File -> View data pyramid from the Main program 
menu. The Data pyramid window will open. 
 
While adding or editing a data set, this window can be opened by clicking on the View current data 

pyramid button. 
 
This window displays your data pyramid as a hierarchical tree, which makes it easy to understand 
where a specific data set fits into the pyramid.  
 
If you have changed the structure of the data pyramid while this window is open, you will have to 
close it and open it again to see the changes.  
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The three data types 
 
PPIP allows you to collect three different data types, all of which are used in different data 
analyses. You can also use PPIP to collect only one or two of these data types, but this obviously 
implies that your data analysis will be more limited. 
 
The three data types correspond to the group of three buttons on the button bar. 
 
The data types you can collect are: 
•  Monthly data 
 This includes the number of births in various birth weight categories, as well as the number of 
stillbirths and neonatal deaths. It also includes some miscellaneous data fields, e.g. number of 
multiple births, delivery method and maternal syphilis serology. Data is entered for a period of 
one month. 
•  Perinatal death 
 More detailed data is entered about each perinatal death. This includes some demographic data, 
as well as causes of death and avoidable factors. 
•  Maternal death 
 Some data is entered about maternal deaths, including some demographic data, as well as 
causes of death. 
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Perinatal deaths entered with monthly data 
 
Why enter perinatal deaths twice? 
 
When you enter Monthly data on the New monthly data window, you not only enter the total 
number of births in each weight category, but you can also enter the number of stillbirths and 
neonatal deaths. Isn't this duplication of data, as you are going to enter detail about the perinatal 
deaths on the New perinatal death window anyway? 
 
Well, yes and no. 
 
The monthly perinatal death entry function was added to allow some users a more basic use of 
PPIP. If you never enter any detailed perinatal death data, but you enter the total perinatal deaths 
with the Monthly data, PPIP still allows the calculation of perinatal mortality rates, although the 
more detailed analyses are not possible. 
 
This implies that there are three ways to implement total perinatal death entries with Monthly 
data: 
 

Three ways to use PPIP 
 
1 - Detailed perinatal death data entry and analysis, no data validity checks  
 
•  Only the first field ("Total births") in every weight category is completed with Monthly data, do 
not enter perinatal death totals here.  
•  Enter detailed data about perinatal deaths.  
  
All data analyses will be possible, but you cannot use the total perinatal deaths to check whether 
detailed data has been entered for all deaths. 
 
To define the program setup for data entry and analysis, select Tools -> Program settings... 
on the Main program menu to open the Program setup window, then… 
 
Disable data entry checks  
 
 

On the Data entry tab, uncheck the Check Perinatal Death Entries against Total 

Births check box and the Check Total Births entries against Perinatal Deaths 

check box. This means that PPIP does not use the perinatal 
deaths entered with Monthly data to check whether detail about 
all these deaths are entered. 

Select appropriate data to 
be used in data analyses 
  
 

On the Data analysis tab, select Use perinatal deaths for which detailed data was 

entered in the Perinatal death data to use for analysis radio button group. 
This will force PPIP to use the detailed perinatal death data when 
doing the data analysis. 
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2 - Detailed perinatal death data entry and analysis, AND data validity check  
 
•  "Total Births", "Stillborn", "Early neonatal deaths" and '"Late neonatal deaths" are completed 
with Monthly data.  
•  Enter detailed data about perinatal deaths.  
  
All data analyses will be possible, AND you will be able to use the data about perinatal deaths 
you entered here to check whether detailed data about all perinatal death was entered. 
 
To define the program setup for data entry and analysis, select Tools -> Program settings... 
on the Main program menu to open the Program setup window, then… 
 
Enable data entry checks On the Data entry tab, you can check the Check Perinatal Death Entries 

against Total Births check box and the Check Total Births entries against 

Perinatal Deaths check box. This means that PPIP uses the perinatal 
deaths entered with Monthly data to check whether detail about 
all these deaths are entered, and it checks whether monthly data 
has been entered which includes a perinatal death just entered. 

Select appropriate data to 
be used in data analyses 

On the Data analysis tab, select Use perinatal deaths for which detailed data was 

entered in the Perinatal death data to use for analysis radio button group. 
This will force PPIP to use the detailed perinatal death data when 
doing the data analysis. 

 
 
3 - Monthly perinatal death data entry ONLY, no data validity checks  
 
•  "Total Births", "Stillborn", "Early neonatal deaths" and '"Late neonatal deaths" are completed 
with Monthly data.  
•  NO detailed data is entered about perinatal deaths.  
  
Only very basic data analysis is possible - total deliveries and perinatal mortality rates, as well as 
miscellaneous data (delivery method, maternal age etc.) can be calculated, but NO causes of 
death or avoidable factors. This is a much more basic way of using PPIP. 
 
To define the program setup for data entry and analysis, select Tools -> Program settings... 
on the Main program menu to open the Program setup window, then… 
 
Disable data entry checks On the Data entry tab, uncheck the Check Perinatal Death Entries against Total 

Births check box and the Check Total Births entries against Perinatal Deaths 

check box. This means that PPIP does not use the perinatal 
deaths entered with Monthly data to check whether detail about 
all these deaths are entered, as these are not entered. 

Select appropriate data to 
be used in data analyses 

On the Data analysis tab, select Use data entered with total deliveries in the 
Perinatal death data to use for analysis radio button group. This will force 
PPIP to use the basic perinatal death data when doing the data 
analyses that are still possible. 
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Entering monthly data 
 

Add monthly data 
 
To add new monthly data, select Insert -> Monthly data from the Main program menu, or 
click on the Add monthly data button on the button bar . The New monthly data window will open. 
 
Enter all the relevant data fields, then click on the OK button to save the data. You can set up 
PPIP to automatically reset the New monthly data window for another entry. This is convenient 
if you have more than one month to enter data for. This function is defined in the Program setup 
window. 
 
Click on the Cancel button to close the window without saving the data.  
 
 
Edit monthly data 
 
To change previously entered monthly data, select Edit -> Monthly data from the Main 
program menu . The Select the month to edit / delete window will open. 
 
The Select the month to edit / delete window displays a list of all the monthly data previously 
entered for the currently selected data set. 
 
Scroll down to the month you want to edit, left-click on it to select the month, then click on the Edit 

button. The Edit monthly delivery data window will be opened, displaying the data as 
previously entered. 
 
(You can also double-click on the month to be opened for editing.) 
 
Click on the Close button to close the list of months to edit.  
 
 
Monthly data entry fields 
 
The first data field you need to complete is the month during which this data was collected, known 
as the data period. Select the correct month from the drop-down list, and use the spin box to enter 
the year. By default the month prior to the current month will be entered for you. 
 
The bigger part of the window is occupied by the data entry fields arranged on two tabs.  
•  Deliveries tab 
 All deliveries and deaths entered here will be subdivided into five groups depending on birth 
weight. The groups are: 
- 500 - 999g 
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- 1000 - 1499g 
- 1500 - 1999g 
- 2000 - 2499g 
- 2500g and more 
 
Use the spin boxes to enter the number of deliveries, stillbirths, early neonatal deaths and late 
neonatal deaths. As you enter the fields, PPIP will display running totals of the different groups. 
 
The perinatal deaths entered here can be used for data analysis, or for checking whether detailed 
perinatal death data has been entered completely. Perinatal deaths entered with monthly data will 
give you more insight into these options. 
 
As the totals you enter here will be used to check the validity of your data on the next tab, it is 
recommended that you should complete the Deliveries tab before completing the entry fields on the 
Miscellaneous tab. 
 
•  Miscellaneous tab 
 The following fields have to be entered:  
•  Multiple births. 
 Enter the number of babies born from multiple pregnancies and the number of multiple 
pregnancies.  
•  Antenatal care 
 Enter the number of patients who received antenatal care at the local institution, those who 
received antenatal care elsewhere, and those who received no antenatal care. PPIP will calculate 
the number of patients where this data is unknown.  
•  Born before arrival 
 Enter the number of women who delivered before reaching the health care facility.  
•  Delivery methods 
 Enter the breakdown of the methods of delivery.  
•  Maternal syphilis serology 
 Enter the number of patients found to have positive and negative syphilis serology. PPIP will 
calculate the number of patients where this data is unknown.  
•  Maternal HIV serology 
 Enter the number of patients found to have positive and negative HIV serology. PPIP will 
calculate the number of patients where this data is unknown.  
•  Age 
 Enter the number of women who delivered during the month who were younger than 18 years, 
those who were 18 to 19 years old, and those who were 35 and older. 
•  Anti-retroviral therapy 
 Enter the number of women with positive HIV serology who received anti-retroviral therapy, and 
the number who did not receive ART. PPIP will calculate the number of patients where this data 
is unknown. (This data entry group will only be available if the Anti-retroviral Therapy Module has 
been activated in the Settings window.) 
 
None of the fields are compulsory. 
 
Click on the OK button to save the data, or click on the Cancel button to close the window without 
saving the data. 
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Delete monthly data 
 
To permanently delete previously entered monthly data, select Edit -> Monthly data from the 
Main program menu. The Select the month to edit / delete window will open. 
 
 The Select the month to edit / delete window displays a list of all the monthly data 
previously entered for the currently selected data set. 
 
Scroll down to the month you want to delete, left-click on it to select the month, then click on the 
Delete button. A message will be displayed to ensure that you really want to delete the data. Click 
on Yes to delete the data, or on No to cancel the action and return to the Select the month to 
edit / delete window. 
 
This action will permanently remove all data entered in the current data set for this month from 
your computer. You cannot undo it!  
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Perinatal deaths 

  
 
Add a perinatal death 
 
To add detail about a perinatal death, select Insert -> Perinatal death from the Main program 
menu, or click on the New perinatal death button on the button bar . The New perinatal death 
window will open. 
 
Enter all the relevant data fields, then click on the OK button to save the data. You can set up PPIP 
to automatically reset the New perinatal death window for another entry. This is convenient if 
you have more than one perinatal death to enter. This function is defined in the Program setup 
window. 
 
Click on the Cancel button to close the window without saving the data. 
 
 
 
Edit a perinatal death 
 
To change detail about a previously entered perinatal death, select Edit -> Perinatal death 
from the Main program menu. The Select the perinatal death to edit window will open. 
 
The Select the perinatal death to edit window displays a list of all the perinatal deaths 
previously entered for the currently selected data set. Two tabs provide two ways of ordering the 
data. The first orders the perinatal deaths by date of delivery, while the second orders the deaths 
according to the ID number allocated to the entries. On the second tab, entering the first 
character of the ID number on your computer's keyboard will scroll down to the first entry with an 
ID number starting with that particular character. 
 
Scroll down to the entry you want to edit, left-click on it to select the perinatal death, then click on 
the Edit button. The Edit perinatal death window will be opened, displaying the data as 
previously entered. 
 
(You can also double-click on the entry to open it for editing.) 
 
Click on the Close button to close the list of perinatal deaths to edit.  
 

 
Perinatal death entry fields 
 
The data fields you need to complete are: 
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The identification number allocated to each perinatal death must be unique. The hospital number 
is often used, but be sure about the confidentiality of your data if you do this. 
•  Date of delivery 
 Enter the date in the format dd/mm/yyyy (or dd/mm/yy which will be converted to the first format). 
You may also use the pop-up calendar to select the date. To open the calendar, click on the ... 
button. 
•  Date of death 
 Enter the date in the format dd/mm/yyyy (or dd/mm/yy which will be converted to the first format). 
You may also use the pop-up calendar to select the date. To open the calendar, click on the ... 
button. 
If the baby was stillborn, enter the date of birth as its date of death, even if the actual date the 
baby died is known. 
•  Birth mass 
 Use the spin box to enter the birth weight in gram. The minimum birth weight that can be entered 
is 500g. 
•  Place delivered 
 From the drop-down list, select from the following options:  
•  Delivered at this unit  
•  Delivered at home  
•  Delivered in transit  
•  Delivered at another unit  
•  Place of delivery unknown 
   
•  Maternal age 
 Use the spin box to enter the mother's age. If her age is unknown, leave the entry field empty 
and check the Unknown check box. 
•  Antenatal care status 
 Indicate whether the mother received antenatal care. From the drop-down list, select from the 
following options:  
•  Yes  
•  No  
•  Unknown 
   
•  Condition at birth 
 Use the radio buttons to indicate the condition of this baby at birth. The possible selections are:  
•  The baby was born alive  
•  The baby was stillborn, but was alive on admission  
•  The baby was stillborn, not macerated, but was already dead on admission  
•  The baby was stillborn, not macerated, and the condition on admission is unknown  
•  The baby was stillborn and macerated at birth 
   
•  Maternal syphilis serology 
 Use the radio buttons to indicate the mother's syphilis serology. The possible selections are:  
•  Positive  
•  Negative  
•  The syphilis serology was not determined  
•  The syphilis serology was determined, but the result is not available 
  

 
 

26 



The Perinatal Problem Identification Program v2.1 
 
 

•  Single / multiple pregnancy 
 Use the radio buttons to indicate whether this was a single or multiple pregnancy. The possible 
selections are:  
•  Single pregnancy  
•  Multiple pregnancy 
   
•  Maternal HIV serology 
 Use the radio buttons to indicate the mother's HIV serology. The possible selections are:  
•  Positive  
•  Negative  
•  The HIV serology was not determined  
•  The HIV serology was determined, but the result is not available 
 
If the maternal HIV serology is entered as 'Positive', and the Anti-retroviral Therapy module has 
been activated in the Program settings, an additional field will appear, allowing you to indicate 
whether this patient has received anti-retroviral therapy. The default entry will be 'Unknown'. Use 
the drop-down list to change this to 'Yes' or 'No' if this is known. 
   
•  Primary obstetric cause of death 
 The primary obstetric cause of perinatal death refers to the particular obstetric condition or 
pathology that initiated the chain of events eventually leading to the baby's death. PPIP is 
distributed with a list of causes, each with a code which identifies the cause. You are not allowed 
to make any changes to this list of causes - this would eventually lead to chaos, as slowly each 
unit would develop its own code list, making data analysis in a data pyramid impossible. 
 
Enter the code for the cause you have identified, or select it from the list of codes by clicking on 
the ... button next to the entry field. The Primary obstetric cause of Perinatal death window 
will open, from which you can select the appropriate code. 
 
If the code you enter refers to a non-specific cause of death (Description: Other), a new entry field 
will be displayed for you to enter the specific description. This description can be up to 30 
characters in length. 
•  Final cause of death 
 The final cause of neonatal death refers to the eventual pathology that claims the baby's life. 
PPIP is distributed with a list of causes, each with a code which identifies the cause. You are not 
allowed to make any changes to this list of causes - this would eventually lead to chaos, as slowly 
each unit would develop its own code list, making data analysis in a data pyramid impossible. 
 
Enter the code for the cause you have identified, or select it from the list of codes by clicking on 
the ... button next to the entry field. The Final cause of Neonatal death window will open, from 
which you can select the appropriate code. 
 
If the code you enter refers to a non-specific cause of death (Description: Other), a new entry field 
will be displayed for you to enter the specific description. This description can be up to 30 
characters in length. 
 
If the baby was stillborn, code 0900 (Intrauterine death) must always be used. 
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identifies it. You are not allowed to make any changes to this list of codes - this would eventually 
lead to chaos, as slowly each unit would develop its own code list, making data analysis in a data 
pyramid impossible. 
 
Enter the code for the avoidable factors you have identified, or select it from the list of codes by 
clicking on the ... button next to the entry field. The Avoidable factors window will open, from 
which you can select the appropriate code. 
 
If the code you enter refers to a non-specific avoidable factor (Description: Other), a new entry 
field will be displayed for you to enter the specific description. This description can be up to 30 
characters in length. 
 
After entering the code, you have to indicate whether this factor possibly or probably could have 
avoided the death. See here for further information on avoidable factors. 
 
As soon as an avoidable factor has been entered, one more entry field will become available, 
allowing a maximum number of five avoidable factors to be entered. 
 
Enter all the relevant data fields, then click on the OK button to save the data, or click on the Cancel 

button to close the window without saving the data.  
 
 
 
Perinatal death codes 

 
Primary cause of perinatal death 
 
The Primary obstetric cause of Perinatal death window displays a list of codes and the 
associated descriptions of primary causes of death. You can use the scroll bar or the Up, Down, 
Page Up, Page Down, Home and End keys to scroll up and down, until the correct cause is in 
view. Select the cause by left-clicking on it, then click on the Select button, or double-click on the 
cause. The code will be entered in the appropriate entry field, and the list of causes will close. 
 
You can print a hard copy of the list of codes and descriptions. Select Tools -> Print code 
lists -> Obstetric cause of perinatal death from the Main program menu. See here for 
more information.  
 
 
Final cause of neonatal death 
 
The Final cause of Neonatal death window displays a list of codes and the associated 
descriptions of final causes of death. You can use the scroll bar or the Up, Down, Page Up, Page 
Down, Home and End keys to scroll up and down, until the correct cause is in view. Select the 
cause by left-clicking on it, then click on the Select button, or double-click on the cause. The code 
will be entered in the appropriate entry field, and the list of causes will close. 
 
You can print a hard copy of the list of codes and descriptions. Select Tools -> Print code 
lists -> Final cause of neonatal death from the Main program menu. See here for more 
information.  
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Avoidable factor 
 
The Avoidable factors window displays a list of codes and the associated descriptions of 
avoidable factors to be used with perinatal deaths. You can use the scroll bar or the Up, Down, 
Page Up, Page Down, Home and End keys to scroll up and down, until the correct cause is in 
view. Select the avoidable factor by left-clicking on it, then click on the Select button, or double-
click on the entry. The code will be entered in the appropriate entry field, and the list of avoidable 
factors will close. 
 
You can print a hard copy of the list of codes and descriptions. Select Tools -> Print code 
lists -> Perinatal death avoidable factors from the Main program menu. See here for more 
information.  
 
What are avoidable factors? 
 
PPIP aims to allow you to go one step further than identifying what killed babies. It takes you all 
the way through the process to the point where you also identify what the circumstances around 
the deaths were with a view to pinpointing where different circumstances may have lead to a 
different outcome. Avoidable factors are identified where "a death is judged to be due to an error 
or omission on the part of the health service or the patient". 
 
When identifying an avoidable factor, therefore, we focus on the patient, the administrative 
system and the medical personnel. A lack of information (case notes) which makes identification 
of possible avoidable factors impossible makes up a fourth group. 
 
Avoidable factor grading 
 
If a specific avoidable factors was present, but the perinatal outcome may have been similar even 
if the particular problem did not exist, this factor is graded Possible cause, i.e. it may have 
caused or facilitated this perinatal death, but not necessarily. On the other hand, if the perinatal 
death would have been avoided if this particular problem had been avoided, this factor is graded 
Probable cause - i.e. it probably caused or facilitated the perinatal death. 
 
An illustration of the difference in grading: A perinatal death is caused by proteinuric 
hypertension. An avoidable factor 'No response to history of stillbirth, abruption etc.' is identified, 
graded Possible cause - even if the medical personnel did respond to the history, the perinatal 
death would not necessarily have been avoided. On the other hand, in the case of a perinatal 
death caused by congenital syphilis, an avoidable factor 'No syphilis screening performed at 
hospital / clinic' is identified, graded Probable cause. This infant probably would have survived 
had it not been for the absent syphilis testing. 
 
 
Delete a perinatal death 
 
To permanently delete a previously entered perinatal death, select Edit -> Perinatal death 
from the Main program menu . The Select the perinatal death to edit window will open. 
 
The Select the perinatal death to edit window displays a list of all the perinatal deaths 
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previously entered for the currently selected data set. Two tabs provide two ways of ordering the 
data. The first orders the perinatal deaths by date of delivery, while the second orders the deaths 
according to the ID number allocated to the entries. On the second tab, entering the first 
character of the ID number on your computer's keyboard will scroll down to the first entry with an 
ID number starting with that particular character. 
 
Scroll down to the entry you want to edit, left-click on it to select the perinatal death, then click on 
the Delete button. A message will be displayed to ensure that you really want to delete the data. 
Click on Yes to delete the data, or on No to cancel the action and return to the Select the 
perinatal death to edit window. 
 
This action will permanently remove data about the selected perinatal death from your computer. 
You cannot undo it!  

 
 

30 



The Perinatal Problem Identification Program v2.1 
 
 

Maternal death 
 
 

Add a maternal death 
 
To add detail about a maternal death, select Insert -> Maternal death from the Main program 
menu, or click on the New maternal death button on the button bar . The New Maternal death 
window will open. 
 
Enter all the relevant data fields, then click on the OK button to save the data. You can set up PPIP 
to automatically reset the New Maternal death window for another entry. This is convenient if 
you have more than one maternal death to enter. This function is defined in the Program setup 
window. 
 
Click on the Cancel button to close the window without saving the data. 
 
 
Edit a maternal death 
 
To change detail about a previously entered maternal death, select Edit -> Maternal death 
from the Main program menu . The Select the maternal death to edit window will open. 
 
The Select the maternal death to edit window displays a list of all the maternal deaths 
previously entered for the currently selected data set. Two tabs provide two ways of ordering the 
data. The first orders the maternal deaths by ID number, while the second orders the deaths 
according to the date of death. On the first tab, entering the ID number on your computer's 
keyboard will scroll down to the first entry with a corresponding ID number. 
 
Scroll down to the entry you want to edit, left-click on it to select the maternal death, then click on 
the Edit button. The Edit maternal death window will be opened, displaying the data as 
previously entered. 
 
(You can also double-click on the entry to open it for editing.) 
  
Click on the Close button to close the list of maternal deaths to edit.  
 
 
  
Maternal death entry fields 
 
The data fields you need to complete are: 
•  Identification 
 This can consist of up to 15 alphanumeric characters and spaces. 
 
The identification number allocated to each maternal death must be unique. The hospital number 
is often used, but be sure about the confidentiality of your data if you do this. 
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•  Date of death 
 Enter the date on which this patient died in the format dd/mm/yyyy (or dd/mm/yy which will be 
converted to the first format). You may also use the pop-up calendar to select the date. To open 
the calendar, click on the ... button. 
•  Stage of pregnancy during which the death occurred 
 From the drop-down list, select from the following options:  

•  During early pregnancy (<20w)  
•  In the antenatal period (I.e. later in pregnancy, but she was still pregnant and not in 
labour when she died.)  
•  Intrapartum  
•  Postpartum  
•  Unknown 
   

•  Primary obstetric cause of death 
 The primary obstetric cause of maternal death refers to the particular obstetric condition or 
pathology that initiated the chain of events eventually leading to the patient's death. PPIP is 
distributed with a list of causes, each with a code which identifies the cause. You are not allowed 
to make any changes to this list of causes - this would eventually lead to chaos, as slowly each 
unit would develop its own code list, making data analysis in a data pyramid impossible. 
 
Enter the code for the cause you have identified, or select it from the list of codes by clicking on 
the ... button next to the entry field. The Obstetric cause of Maternal death window will open, 
from which you can select the appropriate code. 
 
If the code you enter refers to a non-specific cause of death (Description: Other), a new entry field 
will be displayed for you to enter the specific description. This description can be up to 30 
characters in length. 
•  Final causes of death 
 The final cause of maternal death refers to the eventual pathology that claims the patient's life. 
PPIP is distributed with a list of causes, each with a code which identifies the cause. You are not 
allowed to make any changes to this list of causes - this would eventually lead to chaos, as slowly 
each unit would develop its own code list, making data analysis in a data pyramid impossible. 
 
Enter the code for the cause you have identified, or select it from the list of codes by clicking on 
the ... button next to the entry field. The Final cause of maternal death window will open, from 
which you can select the appropriate code. 
 
If the code you enter refers to a non-specific cause of death (Description: Other), a new entry field 
will be displayed for you to enter the specific description. This description can be up to 30 
characters in length. 
 
As soon as a code has been entered, one more entry field will become available, allowing a 
maximum number of three contributory final causes of death to be entered. 
 
Enter all the relevant data fields, then click on the OK button to save the data, or click on the Cancel 

button to close the window without saving the data.  
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Maternal death codes 

 
Obstetric cause of maternal death 
 
The Obstetric cause of Maternal death window displays a list of codes and the associated 
descriptions of primary causes of death. You can use the scroll bar or the Up, Down, Page Up, 
Page Down, Home and End keys to scroll up and down, until the correct cause is in view. Select 
the cause by left-clicking on it, then click on the Select button, or double-click on the cause. The 
code will be entered in the appropriate entry field, and the list of causes will close. 
 
You can print a hard copy of the list of codes and descriptions. Select Tools -> Print code 
lists -> Obstetric cause of maternal death from the Main program menu. See here for 
more information.  
 
 
Final cause of maternal death 
 
The Final cause of Maternal death window displays a list of codes and the associated 
descriptions of final causes of death. You can use the scroll bar or the Up, Down, Page Up, Page 
Down, Home and End keys to scroll up and down, until the correct cause is in view. Select the 
cause by left-clicking on it, then click on the Select button, or double-click on the cause. The code 
will be entered in the appropriate entry field, and the list of causes will close. 
 
You can print a hard copy of the list of codes and descriptions. Select Tools -> Print code 
lists -> Final cause of maternal death from the Main program menu. See here for more 
information. 
 
 
 
Delete a maternal death 
 
To permanently delete a previously entered maternal death, select Edit -> Maternal death 
from the Main program menu . The Select the maternal death to edit window will open. 
 
The Select the maternal death to edit window displays a list of all the maternal deaths 
previously entered for the currently selected data set. Two tabs provide two ways of ordering the 
data. The first orders the maternal deaths by ID number, while the second orders the deaths 
according to the date of death. On the first tab, entering the ID number on your computer's 
keyboard will scroll down to the first entry with a corresponding ID number. 
 
Scroll down to the entry you want to edit, left-click on it to select the maternal death, then click on 
the Delete button. A message will be displayed to ensure that you really want to delete the data. 
Click on Yes to delete the data, or on No to cancel the action and return to the Select the 
maternal death to edit window. 
 
This action will permanently remove data about the selected maternal death from your computer. 
You cannot undo it!  
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Data analysis principles 
 
PPIP presents you with a wide variety of preset data analysis functions. In addition to these, you 
can also export your data files and most data tables to Microsoft Excel for any other data 
manipulation or presentation you may need. 
 
Each data analysis screen allows you, where relevant, to identify exactly which data you want to 
include in the analysis. To make this easier, you can also select two default settings before doing 
the analyses. These are: 
•  Default data analysis dates 
 When a data analysis window is opened, only births and deaths that occurred during the 
selected months will be included. You may change these dates, but setting up a default makes it 
easier to include only specific dates on all windows. If no default data analysis dates are set, all 
data will be included when a data analysis window opens. 
•  Calculation method 
 If the data set you are using has other data sets below it in the data pyramid, you may elect to 
analyse data from all levels as one, or to analyse only the current data set's data. 
 
There are three ways to use the data entry and analysis functions in PPIP. Be sure to use the 
appropriate data analysis method - see here for a description of  ways to set up and use PPIP to 
ensure correct data entry and an appropriate data analysis setup. 
 
Various default data analysis settings can also be defined on the Program setup window's Data 

analysis tab. 
 
All data analysis screens are opened from the Data analysis toolbar. All screens stay open until 
individually closed. You can also set up PPIP to close all data analysis screens when you close 
the Data analysis button bar.  
 
 

How to get to the data analysis functions 
 
All the data analysis functions are accessible from the Data analysis toolbar. To open the 
toolbar, select Data analysis -> Display data analysis toolbar from the Main program 
menu, or click on the Data analysis toggle button on the button bar. A check mark will appear next to 
the menu function, and the toggle button will remain depressed. To close the toolbar, again select 
Data analysis -> Display data analysis toolbar from the Main program menu, or click on 
the Data analysis toggle button on the button bar. The check mark next to the menu function will 
disappear, and the toggle button will return to its normal position. 
 
The toolbar consists of a collection of buttons, grouped by function, which allows all the data 
analysis windows to be accessed. The toolbar can be positioned to the left (default) or right of the 
PPIP work area. To move it, left-click on the toolbar outside a button, hold and drag the toolbar to 
the opposite side. It will 'dock' against the border of the work area. 
 
You are presented with a vertically arranged group of five toggle buttons. Clicking on any of these 
will open a further selection of buttons leading to the data analysis functions. Selecting a new 
toggle button will switch the function buttons to the new group. The buttons are grouped as 
follows: 
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  Toggle button leading to function buttons: 
 

Toggle button Function 
Total deliveries Total deliveries 
 Deliveries per month 
 Compare units 
 Unprocessed data 
Perinatal deaths Mortality rates 
 Monthly mortality 
 Primary causes 
 Final causes 
 Unprocessed data 
Avoidable factors List factors 
 Avoidable mortality 
 Percentage avoidable factors 
Maternal deaths Primary causes 
 Final causes 
 Mortality rate + ratios 
 Unprocessed data 
Miscellaneous Mode of delivery 
 Other 
 
All data analysis functions open in individual windows and all stay open until closed by the user. 
Selecting a data analysis function that is already open will not open a second instance of the 
window, but will bring the original window to view. 
 
You can set up PPIP to automatically close all data analysis windows when you close the data 
analysis toolbar. To enable this function, check the Close data analysis windows with toolbar check box on 
the Data analysis tab of the Program setup window.  
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Default data analysis settings 
 
To set up default data analysis dates and calculation method, select Data analysis -> Select 
default data analysis dates from the Main program menu, or click on the Default dates button on 
the button bar. The Default data analysis dates window will open. 
 
 
Default dates 
 
Each time you open a data analysis window, you can choose to include all data collected or data 
between specific dates only. If you want to look at different data analyses and you want to include 
only certain dates, it is easier to select these dates as default before you do the analyses. The 
Default data analysis dates window allows you to set up these default dates. 
 
Four entry fields are provided to enter the first and last month (inclusive) that you want to define 
as your default data analysis dates. To automatically calculate the first and last month for which 
data was entered, click on the Include all dates button. This is also useful if you want to include, say, 
the last six months: automatically select all dates, and change only the First month to include to six 
months earlier than the Last month to include. 
 
 
Default data calculation method 
 
If the data set you are using has other data sets below it in the data pyramid, you may elect to 
analyse data from all levels as one, or to analyse only the current data set's data. 
 
To include only the currently selected data set's data when your data analysis windows open, 
select the Own data only radio button. To include all lower levels in the data analyses by default, 
select the Cumulative data radio button. If the current data set has no units below it in the data 
pyramid, (i.e. any data analysis will always include only data from this data set) these radio 
buttons will be disabled and Own data only will be selected as default.  
 
You can also set a default data calculation method that will be stored by PPIP between sessions, 
and always used as your default. This is set on the Program setup window's Data analysis tab. 
 
Click on the Close button to close the window.  
 

 
 

36 



The Perinatal Problem Identification Program v2.1 
 
 

Data analysis  
 

Total deliveries 
 
Getting to it 
 
To open the Total deliveries data analysis window, open the Data analysis toolbar, then click on the 
Total deliveries toggle button, which will show the relevant data function buttons. The Totals button will 
open the data analysis window. 
 
Screen controls 
 
You can define the data to be included in this analysis by setting the following: 
•  Dates included 
 Use the drop-down lists and spin boxes to enter the months to include in the analysis. If you 
have previously selected default data analysis dates, these dates will be included when this 
window opens. If no default dates have been set, all data will be included in the analysis. 
•  Data used 
 Use the drop-down list to select the data to use to calculate the perinatal outcome. You can 
select Total delivery data (perinatal deaths entered with Monthly data) or Detailed perinatal death data 

(detailed Perinatal death entries). 
 
If you choose to use perinatal deaths entered with Monthly data (Total delivery data), a total number 
of stillborn babies will be calculated, but no further breakdown (Alive on admission, Dead on 
admission, Admission status unknown and Macerated) is done, as the available data does not 
allow this. 
•  Calculation method 
 Use the drop-down list to indicate whether you want data only from the currently selected data 
set to be included in the analysis (Own data only), or this data set and all those below it in the data 
pyramid (Cumulative data). 
 
If your data pyramid setup does not show any data sets below the currently selected data set, this 
drop-down list will be disabled, and Own data only will always be selected. 
 
Data analysis 
 
This window displays three groups of information: 
•  Neonates delivered 
 A table showing the total number of babies delivered in each of the five birth weight groups, also 
displayed as a percentage of the total number of deliveries in all weight groups. 
 
Click on the Transfer to MS Excel button to transfer this data table to Microsoft Excel. A new Excel 
sheet named 'Total deliveries' will be created. 
•  Selected birth weight categories 
 To calculate the combined number of deliveries in certain weight groups, check the check boxes 
of the birth weight categories you want to include. A total number of deliveries and percentage of 
all deliveries will be displayed. 
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•  Perinatal outcome 
 Again, you may select which birth weight categories you want to include in this analysis. Check 
the check boxes of the birth weight categories you want to include. The following will be 
calculated: 

•  Total number (and percentage of all births) of infants born alive.  
•  Total number (and percentage of all live born babies) of surviving infants.  
•  Total number (and percentage of all live born babies) of early neonatal deaths.  
•  Total number (and percentage of all live born babies) of late neonatal deaths.  
•  Total number (and percentage of all births) of stillborn infants.  
•  Total number (and percentage of all stillborn babies) of stillbirths where the baby was 
alive on admission.  
•  Total number (and percentage of all stillborn babies) of fresh stillbirths where the baby 
was dead on admission.  
•  Total number (and percentage of all stillborn babies) of fresh stillbirths where the 
baby's condition on admission is unknown.  
•  Total number (and percentage of all stillborn babies) of macerated stillbirths. 

 

Print the data 
 
To print the data analysis, click on the Print button. Depending on your program setup, you may be 
presented with the Select printout format window to select which of the three information 
groups described above you want to include in the printout, or, if you have set up a default 
printout format, the print preview will be displayed, ready to print the report. 
 
Close 
 
Click on the Close button to close this window. Depending on your program setup, the window will 
also close when the Data analysis toolbar is closed.  

  

 
 
Define report - Total deliveries 
 
When you print the data presented on the Total deliveries data analysis window, you can 
include one or more of the information groups this window presents. Before the data is printed, 
the Select printout format window prompts you to select the data to be printed. 
 
By checking the relevant check boxes, you can print: 
•  Neonates delivered  
•  Selected birth weights  
•  Perinatal outcome 
  
If you always want to include the same information group(s) in your printout without being 
prompted every time, check the Use this as default, then don't ask me again check box. To change this 
setup, you can open the Program setup window, go to the Data printouts tab, and change the 
defaults in the Total births printout group. 
 
Click on the Print button to proceed with the printout. You will be presented with a preview of the 
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printout, and can then proceed to print the data. 
 
Click on the Cancel button to cancel the process without printing the report.  
 
 
 
Deliveries per month 
 
Getting to it 
 
To open the Deliveries per month data analysis window, open the Data analysis toolbar, then click 
on the Total deliveries toggle button, which will show the relevant data function buttons. The Deliveries 

per month button will open the data analysis window. 
 
Screen controls 
 
You can define the data to be included in this analysis by setting the following: 
•  Data period 
 Use the drop-down list to specify the number of months / years to include in the graph. If you 
have previously specified a default data period for time graphs in your program setup, this will be 
used when the window opens. If no default data period has been set, the last six months' data will 
be displayed in the graph. 
 
You can display six months, one year, two years, five years or all data in the time graph. 
•  Data used 
 Because only Monthly data is used to create this graph, this will always be set to Total delivery data 

and the drop-down list will be disabled. 
•  Calculation method 
 Use the drop-down list to indicate whether you want data only from the currently selected data 
set to be included in the analysis (Own data only), or this data set and all those below it in the data 
pyramid (Cumulative data). 
 
If your data pyramid setup does not show any data sets below the currently selected data set, this 
drop-down list will be disabled, and Own data only will always be selected. 
•  Scroll buttons 
 The First data button will scroll the graph all the way back to the first month for which data was 
entered. 
 
The Back half screen button will scroll back the graph half a screen, i.e. it will move the graph back in 
time 50% of the Data period currently being displayed. 
 
The Forward half screen button will scroll the graph forward half a screen, i.e. it will move the graph 
forward in time 50% of the Data period currently being displayed. 
 
The Last data button will scroll the graph all the way forward to the last month for which data was 
entered. 
•  Include data 
 When the window opens, births in all five birth weight groups are displayed in the graph. By 
checking or unchecking the birth weight check boxes, you can select which birth weight groups to 
display. 
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Data analysis 
 
This window displays the number of births in the five birth weight categories reported per month. 
On the Graph tab the data is presented in a time graph containing cumulative bars, on which each 
birth weight category is represented by a different colour, with a legend below the graph 
identifying the birth weight groups. The Data tab displays the same information, but as a table 
containing the actual numbers of births. 
 
The data presented in the table can be transferred to Microsoft Excel by clicking on the Transfer to 

MS Excel button. A new Excel sheet named 'Deliveries per month' will be created. 
 
 
Print the data 
 
To print the graph or data table, click on the Print button. The print preview will be displayed, ready 
to print the report. 
 
Close 
 
Click on the Close button to close this window. Depending on your program setup, the window will 
also close when the Data analysis toolbar is closed.  
 
 
 
Compare units 
 
Getting to it 
 
To open the Compare units data analysis window, open the Data analysis toolbar, then click on the 
Total deliveries toggle button, which will show the relevant data function buttons. The Compare units 

button will open the data analysis window. 
 
If your data pyramid setup does not show any data sets below the currently selected data set, the 
Compare units button will be disabled. 
 
Screen controls 
 
You can define the data to be included in this analysis by setting the following: 
•  Dates included 
 Use the drop-down lists and spin boxes to enter the months to include in the analysis. If you 
have previously selected default data analysis dates, these dates will be included when this 
window opens. If no default dates have been set, all data will be included in the analysis. 
•  Data used 
 Use the drop-down list to select the data to use to calculate the number of perinatal deaths. You 
can select Total delivery data (perinatal deaths entered with Monthly data) or Detailed perinatal death data 

(detailed Perinatal death entries). 
•  Calculation method 
 Use the drop-down list to indicate whether you want only data from each data set to be included 
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in the numbers shown for that particular data set (Own data only), or whether the data of all data sets 
below it in the data pyramid should be included in its totals (Cumulative data). 
•  Include data 
 When the window opens, the table includes all births. By checking or unchecking the relevant 
check boxes, you can include or exclude stillbirths, early neonatal deaths, late neonatal deaths 
and survivors in the table. 
 
 
Data analysis 
 
This table displays the number of births at different levels of units (data sets) in the five birth 
weight categories, as well as the total number of deliveries. Perinatal deaths can be included or 
excluded. 
 
The data presented in the table can be transferred to Microsoft Excel by clicking on the Transfer to 

MS Excel button. A new Excel sheet named 'Delivery comparison' will be created. 
 
 
Print the data 
 
To print the data table, click on the Print button. The print preview will be displayed, ready to print 
the report. 
 
Close 
 
Click on the Close button to close this window. Depending on your program setup, the window will 
also close when the Data analysis toolbar is closed.  
 

 
Unprocessed monthly data 
 
Getting to it 
 
To open the Unprocessed total delivery data data analysis window, open the Data analysis 

toolbar, then click on the Total deliveries toggle button, which will show the relevant data function 
buttons. The Unprocessed data button will open the data analysis window. 
 
Screen controls 
 
You can define the data to be included in this table by setting the following: 
•  Dates included 
 Use the drop-down lists and spin boxes to enter the months to include in the table. If you have 
previously selected default data analysis dates, these dates will be included when this window 
opens. If no default dates have been set, all data will be included in the table. 
•  Data used 
 Because only Monthly data is used to create this table, this will always be set to Total delivery data 

and the drop-down list will be disabled. 
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•  Calculation method 
 Use the drop-down list to indicate whether you want data only from the currently selected data 
set to be included in the analysis (Own data only), or this data set and all those below it in the data 
pyramid (Cumulative data). 
 
If your data pyramid setup does not show any data sets below the currently selected data set, this 
drop-down list will be disabled, and Own data only will always be selected. 
•  Reverse sort order 
 When the window opens, the data will be sorted according to date, starting at the oldest entries. 
This sort order can be reversed to show the most recent data at the top of the table. To reverse 
the sort order, click on the Reverse sort order button. 
 
Data analysis 
 
This table displays the number of stillbirths, early neonatal deaths, late neonatal deaths, survivors 
and total births in the five birth weight categories, as well as totals in all categories, as entered 
with Monthly data. The data is presented as it appears in the data file - if you do not enter 
perinatal deaths with Monthly data , no deaths will be reflected here. 
 
The data presented in the table can be transferred to Microsoft Excel by clicking on the Transfer to 

MS Excel button. A new Excel sheet named 'Total deliveries Raw data' will be created. 
 
 
Print the data 
 
To print the data table, click on the Print button. The print preview will be displayed, ready to print 
the report. 
 
Close 
 
Click on the Close button to close this window. Depending on your program setup, the window will 
also close when the Data analysis toolbar is closed.  
 

 
 
Fetal, Perinatal & neonatal mortality rates 
 
Getting to it 
 
To open the Perinatal mortality rates data analysis window, open the Data analysis toolbar, then 
click on the Perinatal deaths toggle button, which will show the relevant data function buttons. The 
Mortality rates button will open the data analysis window. 
 
Screen controls 
 
You can define the data to be included in this analysis by setting the following: 
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•  Dates included 
 Use the drop-down lists and spin boxes to enter the months to include in the table. If you have 
previously selected default data analysis dates, these dates will be included when this window 
opens. If no default dates have been set, all data will be included in the table. 
•  Data used 
 Use the drop-down list to select the data to use to calculate the perinatal outcome. You can 
select Total delivery data (perinatal deaths entered with Monthly data) or Detailed perinatal death data 

(detailed Perinatal death entries). 
 
If you choose to use perinatal deaths entered with Monthly data (Total delivery data), the perinatal 
mortality rates for multiple pregnancies will not be calculated, as the available data does not allow 
this. 
•  Calculation method 
 Use the drop-down list to indicate whether you want data only from the currently selected data 
set to be included in the analysis (Own data only), or this data set and all those below it in the data 
pyramid (Cumulative data). 
 
If your data pyramid setup does not show any data sets below the currently selected data set, this 
drop-down list will be disabled, and Own data only will always be selected. 
 
Data analysis 
 
This window displays its data on two tabs. The Data tab is displayed when the window opens, 
providing you with the following analyses: 
•  Mortality rates and ratios 
 The mortality rates & ratios are calculated for all birth weight groups, all birth weight groups more 
than 1,000g and for each of the five separate birth weight categories, as well as for multiple 
pregnancies (all birth weights). The following rates and ratios are calculated:  

•  Perinatal mortality rate  
•  Neonatal mortality rate  
•  Early neonatal mortality rate  
•  Fetal death ratio  
•  Fetal death rate 
  

The data presented in the table can be transferred to Microsoft Excel by clicking on the Transfer to 

MS Excel button. A new Excel sheet named 'Perinatal mortality rates' will be created. 
 
Click on the Information on calculation of rates and ratios button to view information on how these rates and 
ratios are calculated. 
•  Mortality rates & ratios: selected birth weight categories 
 Check the relevant check boxes to calculate the mortality rates displayed above for a 
combination of birth weight categories. In this way you can calculate the rates for low birth weight 
babies, very low birth weight babies and extremely low birth weight babies. 
•  Stillborn/Neonatal death ratio 
   
•  Perinatal Care Index 
  
The Graphs tab displays two bar graphs. To the left is a representation of perinatal mortality rates in 
the different birth weight categories, and to the right of neonatal mortality rates in the same 
categories. 
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Print the data 
 
To print the graph or data, click on the Print button. The print preview will be displayed, ready to 
print the report. 
 
Close 
 
Click on the Close button to close this window. Depending on your program setup, the window will 
also close when the Data analysis toolbar is closed.  
 

 
Define report - Fetal, Perinatal & neonatal mortality rates 
 
Select the parts of the report you want to include in the printout. 
 
If you always want to print the same part(s) of this report, select the parts of the report to be 
printed, then check the Use this as default, then don't ask me again check box. This default setup can be 
changed in the Program setup window. 
 
Click on the Print button to preview the printout and print it. 
 
Click on the Cancel printing button to close this window without printing the report.  
 
 
 
Information on calculation of rates & ratios 
 
The Calculation of rates & ratios screen shows you how the perinatal mortality rate, neonatal 
mortality rate, early neonatal mortality rate, fetal death ratio and fetal death rate are calculated. It 
also reminds you that, in version 1, PPIP included all deaths in the calculation of its perinatal 
mortality rate, not only the deaths in the perinatal period as defined in the actual perinatal 
mortality rate. (It therefore actually calculated a 'Perinatal related Mortality rate'.)  
 
You can now choose to continue using all deaths (including late neonatal deaths), or you can 
exclude the late neonatal deaths and adhere strictly to the definition as provided above. To use 
the true perinatal mortality rate (excluding late neonatal deaths), select the Include only deaths in 

perinatal period radio button. To include all deaths (use a Perinatal 'related' mortality rate), select the 
Include deaths in perinatal and late neonatal period radio button. 
 
This selection can also be made on the Program setup window - see here for more information.  
 
 
 
Monthly perinatal mortality rate 
 
Getting to it 
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To open the Monthly perinatal mortality rate data analysis window, open the Data analysis 

toolbar, then click on the Perinatal deaths toggle button, which will show the relevant data function 
buttons. The Monthly mortality button will open the data analysis window. 
 
Screen controls 
 
You can define the data to be included in this analysis by setting the following: 
•  Data period 
 Use the drop-down list to specify the number of months / years to include in the graph. If you 
have previously specified a default data period for time graphs in your program setup, this will be 
used when the window opens. If no default data period has been set, the last six months' data will 
be displayed in the graph. 
 
You can display six months, one year, two years, five years or all data in the time graph. 
•  Data used 
 Use the drop-down list to select the data to use to calculate the perinatal outcome. You can 
select Total delivery data (perinatal deaths entered with Monthly data) or Detailed perinatal death data 

(detailed Perinatal death entries). 
•  Calculation method 
 Use the drop-down list to indicate whether you want data only from the currently selected data 
set to be included in the analysis (Own data only), or this data set and all those below it in the data 
pyramid (Cumulative data). 
 
If your data pyramid setup does not show any data sets below the currently selected data set, this 
drop-down list will be disabled, and Own data only will always be selected. 
•  Scroll buttons 
 The First data button will scroll the graph all the way back to the first month for which data was 
entered. 
 
The Back half screen button will scroll back the graph half a screen, i.e. it will move the graph back in 
time 50% of the Data period currently being displayed. 
 
The Forward half screen button will scroll the graph forward half a screen, i.e. it will move the graph 
forward in time 50% of the Data period currently being displayed. 
 
The Last data button will scroll the graph all the way forward to the last month for which data was 
entered. 
•  Include data 
 When the window opens, births in all five birth weight groups are included in the mortality rate 
displayed in the graph. By checking or unchecking the birth weight check boxes, you can select 
which birth weight groups to include in the calculation. 
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•  Display 
 The graph consists of two parts. A bar graph (blue) represents the actual perinatal mortality rate 
for a given month, while a line graph (red) represents the three-month moving average of the 
actual values. Either of these or both can be displayed by checking or unchecking the Actual PNMR 

and 3-month moving average check boxes. 
 
Data analysis 
 
This window displays its data on two tabs. The Graph tab is displayed when the window opens, 



The Perinatal Problem Identification Program v2.1 
 
 

consisting of blue bars representing the actual perinatal mortality rate for a month, and a red line 
representing the three-month moving average of the values. 
 
The Data tab displays the data presented in the graph. When the window opens, the data will be 
sorted according to date, starting at the oldest entries. This sort order can be reversed to show 
the most recent data at the top of the table. To reverse the sort order, click on the Reverse sort order 

button. 
 
The data presented in the table can be transferred to Microsoft Excel by clicking on the Transfer to 

MS Excel button. A new Excel sheet named 'PNMR over time' will be created. 
 
Print the data 
 
To print the graph or data, click on the Print button. The print preview will be displayed, ready to 
print the report. 
 
Close 
 
Click on the Close button to close this window. Depending on your program setup, the window will 
also close when the Data analysis toolbar is closed.  
 

 
Primary cause of perinatal death 
 
Getting to it 
 
To open the Primary obstetric cause of perinatal death data analysis window, open the Data 

analysis toolbar, then click on the Perinatal deaths toggle button, which will show the relevant data 
function buttons. The Primary causes button will open the data analysis window. 
 
Screen controls 
 
You can define the data to be included in this analysis by setting the following: 
•  Dates included 
 Use the drop-down lists and spin boxes to enter the months to include in the table. If you have 
previously selected default data analysis dates, these dates will be included when this window 
opens. If no default dates have been set, all data will be included in the table. 
•  Data used 
 Because detailed Perinatal death data is used to create this data table, this will always be set to 
Detailed perinatal death data and the drop-down list will be disabled. 
•  Calculation method 
 Use the drop-down list to indicate whether you want data only from the currently selected data 
set to be included in the analysis (Own data only), or this data set and all those below it in the data 
pyramid (Cumulative data). 
 
If your data pyramid setup does not show any data sets below the currently selected data set, this 
drop-down list will be disabled, and Own data only will always be selected. 
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•  Display 
 By default the data table displays group headings as well as the individual sub-items under these 
headings. You can display either or both of these by checking or unchecking the Headings and Items 

check boxes. 
 
If no deaths were recorded due to a specific cause, the particular item will not be displayed. If you 
want to include all the items with zero values, check the Zero items check box. 
 
Data analysis 
 
This window displays its data on two tabs. The Data tab is visible when the window opens, 
presenting you with a data table which summarizes the primary obstetric causes of perinatal 
death, ordered from the most to the least common. The total number of perinatal deaths is also 
calculated. 
 
You can use the data filter to specify any subgroup of data you want to include in the analysis. 
See below for a detailed description of the data filter. 
 
The data presented in the table can be transferred to Microsoft Excel by clicking on the Transfer to 

MS Excel button. A new Excel sheet named 'Primary causes Perinatal death' will be created. 
 
The Graph tab presents the data as a pie graph. You can display either the groups of causes 
(headings) or the specific causes of death (items). Use the Display drop-down list to select either 
Headings or Items, then click on the Update graph button. 
 
The pie can consist of up to ten 'slices', each representing a heading or item, and one additional 
'slice' grouping all the remaining headings or items as 'Other'. Use the Include top xx headings/items spin 
box to indicate the number of slices you want to be displayed, then click on the Update graph button. 
 
Print the data 
 
To print the table or graph, click on the Print button. The print preview will be displayed, ready to 
print the report. 
 
Close 
 
Click on the Close button to close this window. Depending on your program setup, the window will 
also close when the Data analysis toolbar is closed.  
 
 
 
Primary cause of perinatal death – Data filter 
 
By using a data filter, PPIP allows the analysis of subgroups of data when creating the list of the 
primary causes of perinatal death. 
 
When the Primary obstetric cause of perinatal death window opens, all perinatal deaths 
within the specified dates are included in the list. To switch to the filter view, click on the Set up filters 

button. You will be presented with a list of possible data filters, all initially disabled, i.e. Select all is 
checked. Uncheck a specific filter's Select all check box to enable it and to proceed to identify the 
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subgroup to use in the data analysis. 
 
Checking a filter item really tells PPIP to look only at perinatal deaths where the following is true... 
Or, seen in the opposite way,  unchecking an item means all deaths where that particular fact it 
true will be disregarded when the list of causes of death is drawn up. 
 
Example: If the birth weight group 500 - 999g is unchecked in the filter setup, all deaths where the 
birth weight was 500g to 999g will be ignored when PPIP goes through the data to create the 
data table. 
 
The following filters are available: 
•  Time of perinatal death 
 You can include or exclude neonates who were:  

•  Early neonatal deaths  
•  Late neonatal deaths  
•  Macerated stillborn  
•  Stillborn, alive on admission  
•  Fresh stillborn, dead on admission  
•  Fresh stillborn, admission status unknown 
  
Check Include all to disregard this item and therefore include all deaths irrespective of the 
baby's condition at birth. 

•  Birth weight 
 You can specify the birth weight categories you want to include or exclude, or you can include 
specific birth weights by checking the Specify check box and entering a minimum and maximum 
birth weight to include. 
 
Check Include all to disregard this item and therefore include all deaths irrespective of the baby's 
birth weight. 
•  Place of birth 
 You can include or exclude neonates who were born:  

•  At this unit  
•  At home  
•  In transit  
•  At another unit  
•  At an unknown place 
  
Check Include all to disregard this item and therefore include all deaths irrespective of the 
baby's place of birth. 

•  Maternal syphilis serology 
 You can include or exclude deaths where the maternal syphilis serology was:  

•  Positive  
•  Negative  
•  Not done  
•  Done, but the result not available 
  
Check Include all to disregard this item and therefore include all deaths irrespective of the 
maternal syphilis serology. 
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•  Maternal HIV serology 
 You can include or exclude deaths where the maternal HIV serology was:  

•  Positive  
•  Negative  
•  Not done  
•  Done, but the result not available 
  
Check Include all to disregard this item and therefore include all deaths irrespective of the 
maternal HIV serology. 
 

•  Anti-retroviral therapy 
You can include or exclude deaths where anti-retroviral therapy: 

•  Was used 
•  Was not used 
•  Use was unknown 

 
Check Include all to disregard this item and therefore include all deaths irrespective of anti-
retroviral therapy use. 
 
This data filter will only be available if the Anti-retroviral Therapy Module has been 
activated in the Settings window. 
 

•  Maternal age 
 You can include only deaths where the maternal age was between specific values. Check 
Unknown to include the perinatal deaths where the maternal age was unknown. 
 
Check Include all to disregard this item and therefore include all deaths irrespective of the maternal 
age. 
•  Antenatal care 
 You can include or exclude perinatal deaths where the mother did, or did not receive antenatal 
care, or where this information was unknown. 
 
Check Include all to disregard this item and therefore include all deaths irrespective of the antenatal 
care. 
•  Number of infants 
 You can include only singleton or only multiple pregnancies. 
 
Check Include all to disregard this item and therefore include both singleton and multiple 
pregnancies. 
•  Final cause of death 
 You can include only perinatal deaths where a specific final cause of neonatal death was 
identified. Use the drop-down list to select the final cause to use as filter. 
 
If you select a specific final cause of death, only perinatal deaths where this cause was identified 
will be analyzed. If you select a heading, all the specific causes of death under the heading will be 
included. 
 
Check Include all to disregard this item and therefore include all final causes of neonatal death. 
•  Avoidable factor 
 You can include only perinatal deaths where a specific avoidable factor was identified. Use the 
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drop-down list to select the avoidable factor to use as filter, and to indicate which grades of 
avoidable factors must be included in the filter - Possible, Probable or both grades. 
 
If you select a specific avoidable factor, only perinatal deaths where this factor was identified will 
be analyzed. If you select a heading, all the specific avoidable factors under the heading will be 
included. 
 
Check Include all to disregard this item and therefore include all avoidable factors. 
 
Once you have set up the filters you want to use, click on the Apply filters button to return to the data 
table. The filters you have set up will be indicated with a check , while the inactive filters are 
marked with a cross . The number of perinatal deaths which meet the filter criteria will also be 
displayed.  
 
 
 
Final cause of neonatal death 
 
Getting to it 
 
To open the Final cause of neonatal death data analysis window, open the Data analysis toolbar, 
then click on the Perinatal deaths toggle button, which will show the relevant data function buttons. 
The Final causes button will open the data analysis window. 
 
Screen controls 
 
You can define the data to be included in this analysis by setting the following: 
•  Dates included 
 Use the drop-down lists and spin boxes to enter the months to include in the table. If you have 
previously selected default data analysis dates, these dates will be included when this window 
opens. If no default dates have been set, all data will be included in the table. 
•  Data used 
 Because detailed Perinatal death data is used to create this data table, this will always be set to 
Detailed perinatal death data and the drop-down list will be disabled. 
•  Calculation method 
 Use the drop-down list to indicate whether you want data only from the currently selected data 
set to be included in the analysis (Own data only), or this data set and all those below it in the data 
pyramid (Cumulative data). 
 
If your data pyramid setup does not show any data sets below the currently selected data set, this 
drop-down list will be disabled, and Own data only will always be selected. 
•  Display 
 By default the data table displays group headings as well as the individual sub-items under these 
headings. You can display either or both of these by checking or unchecking the Headings and Items 

check boxes. 
 
If no deaths were recorded due to a specific cause, the particular item will not be displayed. If you 
want to include all the items with zero values, check the Zero items check box. 
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Data analysis 
 
This window displays its data on two tabs. The Data tab is visible when the window opens, 
presenting you with a data table which summarizes the final causes of neonatal death, ordered 
from the most to the least common. The total number of neonatal deaths is also calculated. 
 
You can use the data filter to specify any subgroup of data you want to include in the analysis. 
See below for a detailed description of the data filter. 
 
The data presented in the table can be transferred to Microsoft Excel by clicking on the Transfer to 

MS Excel button. A new Excel sheet named 'Final causes Neonatal death' will be created. 
 
The Graph tab presents the data as a pie graph. You can display either the groups of causes 
(headings) or the specific causes of death (items). Use the Display drop-down list to select either 
Headings or Items, then click on the Update graph button. 
 
The pie can consist of up to ten 'slices', each representing a heading or item, and one additional 
'slice' grouping all the remaining headings or items as 'Other'. Use the Include top xx headings/items spin 
box to indicate the number of slices you want to be displayed, then click on the Update graph button. 
 
Print the data 
 
To print the table or graph, click on the Print button. The print preview will be displayed, ready to 
print the report. 
 
Close 
 
Click on the Close button to close this window. Depending on your program setup, the window will 
also close when the Data analysis toolbar is closed.  
 
 
Final causes of neonatal death – Data filter 
 
By using a data filter, PPIP allows the analysis of subgroups of data when creating the list of the 
final causes of neonatal death. 
 
When the Final cause of neonatal death window opens, all neonatal deaths within the 
specified dates are included in the list. To switch to the filter view, click on the Set up filters button. 
You will be presented with a list of possible data filters, all initially disabled, i.e. Select all is checked. 
Uncheck a specific filter's Select all check box to enable it and to proceed to identify the subgroup to 
use in the data analysis. 
 
Checking a filter item really tells PPIP to look only at neonatal deaths where the following is true... 
Or, seen in the opposite way,  unchecking an item means all deaths where that particular fact it 
true will be disregarded when the list of causes of death is drawn up. 
 
Example: If the birth weight group 500 - 999g is unchecked in the filter setup, all deaths where the 
birth weight was 500g to 999g will be ignored when PPIP goes through the data to create the 
data table. 
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The following filters are available: 
•  Time of perinatal death 
 You can include or exclude neonates who were:  

•  Early neonatal deaths  
•  Late neonatal deaths  
•  Macerated stillborn  
•  Stillborn, alive on admission  
•  Fresh stillborn, dead on admission  
•  Fresh stillborn, admission status unknown 
  
Check Include all to disregard this item and therefore include all deaths irrespective of the 
baby's condition at birth. 

•  Birth weight 
 You can specify the birth weight categories you want to include or exclude, or you can include 
specific birth weights by checking the Specify check box and entering a minimum and maximum 
birth weight to include. 
 
Check Include all to disregard this item and therefore include all deaths irrespective of the baby's 
birth weight. 
•  Place of birth 
 You can include or exclude neonates who were born:  

•  At this unit  
•  At home  
•  In transit  
•  At another unit  
•  At an unknown place 
  
Check Include all to disregard this item and therefore include all deaths irrespective of the 
baby's place of birth. 

•  Maternal syphilis serology 
 You can include or exclude deaths where the maternal syphilis serology was:  

•  Positive  
•  Negative  
•  Not done  
•  Done, but the result not available 
  
Check Include all to disregard this item and therefore include all deaths irrespective of the 
maternal syphilis serology. 

•  Maternal HIV serology 
 You can include or exclude deaths where the maternal HIV serology was:  

•  Positive  
•  Negative  
•  Not done  
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•  Anti-retroviral therapy 
You can include or exclude deaths where anti-retroviral therapy: 

•  Was used 
•  Was not used 
•  Use was unknown 

 
Check Include all to disregard this item and therefore include all deaths irrespective of anti-
retroviral therapy use. 
 
This data filter will only be available if the Anti-retroviral Therapy Module has been 
activated in the Settings window. 
 

•  Maternal age 
 You can include only deaths where the maternal age was between specific values. Check 
Unknown to include the neonatal deaths where the maternal age was unknown. 
 
Check Include all to disregard this item and therefore include all deaths irrespective of the maternal 
age. 
•  Antenatal care 
 You can include or exclude neonatal deaths where the mother did, or did not receive antenatal 
care, or where this information was unknown. 
 
Check Include all to disregard this item and therefore include all deaths irrespective of the antenatal 
care. 
•  Number of infants 
 You can include only singleton or only multiple pregnancies. 
 
Check Include all to disregard this item and therefore include both singleton and multiple 
pregnancies. 
•  Primary cause of death 
 You can include only neonatal deaths where a specific primary obstetric cause of perinatal death 
was identified. Use the drop-down list to select the primary cause to use as filter. 
 
If you select a specific primary cause of death, only neonatal deaths where this cause was 
identified will be analyzed. If you select a heading, all the specific causes of death under the 
heading will be included. 
 
Check Include all to disregard this item and therefore include all primary causes of perinatal death. 
•  Avoidable factor 
 You can include only neonatal deaths where a specific avoidable factor was identified. Use the 
drop-down list to select the avoidable factor to use as filter, and to indicate which grades of 
avoidable factors must be included in the filter - Possible, Probable or both grades. 
 
If you select a specific avoidable factor, only neonatal deaths where this factor was identified will 
be analyzed. If you select a heading, all the specific avoidable factors under the heading will be 
included. 
 
Check Include all to disregard this item and therefore include all avoidable factors. 
 
Once you have set up the filters you want to use, click on the Apply filters button to return to the data 
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table. The filters you have set up will be indicated with a check , while the inactive filters are 
marked with a cross . The number of neonatal deaths which meet the filter criteria will also be 
displayed.  
 
 
Unprocessed perinatal death data 
 
Getting to it 
 
To open the Unprocessed Perinatal Death data data analysis window, open the Data analysis 

toolbar, then click on the Perinatal deaths toggle button, which will show the relevant data function 
buttons. The Unprocessed data button will open the data analysis window. 
 
Screen controls 
 
You can define the data to be included in this table by setting the following: 
•  Dates included 
 Use the drop-down lists and spin boxes to enter the months to include in the table. If you have 
previously selected default data analysis dates, these dates will be included when this window 
opens. If no default dates have been set, all data will be included in the table. 
•  Data used 
 Because detailed Perinatal death data is used to create this data table, this will always be set to 
Detailed perinatal death data and the drop-down list will be disabled. 
•  Calculation method 
 Use the drop-down list to indicate whether you want data only from the currently selected data 
set to be included in the analysis (Own data only), or this data set and all those below it in the data 
pyramid (Cumulative data). 
 
If your data pyramid setup does not show any data sets below the currently selected data set, this 
drop-down list will be disabled, and Own data only will always be selected. 
•  Reverse sort order 
 When the window opens, the data will be sorted according to date, starting at the oldest entries. 
This sort order can be reversed to show the most recent data at the top of the table. To reverse 
the sort order, click on the Reverse sort order button. 
 
Data analysis 
 
This table displays the following data fields contained in the Perinatal Death data file: 
•  User ID  
•  Delivery date  
•  Date of death  
•  Place delivered  
•  Birth mass  
•  Maternal age  
•  Antenatal care  
•  Condition at delivery  
•  Maternal syphilis serology  
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•  Single or multiple pregnancy  
•  Obstetric and final causes of death (Codes)  
•  Avoidable factors 
  
The data is presented as it appears in the data file - no data manipulation takes place. 
 
The data presented in the table can be transferred to Microsoft Excel by clicking on the Transfer to 

MS Excel button. A new Excel sheet named 'Perinatal deaths Raw data' will be created. 
 
 
Print the data 
 
To print the data table, click on the Print button. The print preview will be displayed, ready to print 
the report. 
 
Close 
 
Click on the Close button to close this window. Depending on your program setup, the window will 
also close when the Data analysis toolbar is closed.  
 
 
List avoidable factors 
 
Getting to it 
 
To open the Avoidable factors associated with perinatal deaths data analysis window, 
open the Data analysis toolbar, then click on the Avoidable factors toggle button, which will show the 
relevant data function buttons. The List factors button will open the data analysis window. 
 
Screen controls 
 
You can define the data to be included in this analysis by setting the following: 
•  Dates included 
 Use the drop-down lists and spin boxes to enter the months to include in the table. If you have 
previously selected default data analysis dates, these dates will be included when this window 
opens. If no default dates have been set, all data will be included in the table. 
•  Data used 
 Because detailed Perinatal death data is used to create this data table, this will always be set to 
Detailed perinatal death data and the drop-down list will be disabled. 
•  Calculation method 
 Use the drop-down list to indicate whether you want data only from the currently selected data 
set to be included in the analysis (Own data only), or this data set and all those below it in the data 
pyramid (Cumulative data). 
 
If your data pyramid setup does not show any data sets below the currently selected data set, this 
drop-down list will be disabled, and Own data only will always be selected. 
•  Percentage method 
 For each item (avoidable factor) a percentage of total is calculated. Because up to five avoidable 
factors can be identified for each perinatal death, you can select either to calculate the 
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percentage of the total number of deaths (use the % of drop-down list to select Deaths) or the 
percentage of the total number of avoidable factors identified in all the deaths (use the % of drop-
down list to select Codes). 
•  Display 
 By default the data table displays group headings as well as the individual sub-items under these 
headings. You can display either or both of these by checking or unchecking the Headings and Items 

check boxes. 
 
If no deaths were recorded due to a specific cause, the particular item will not be displayed. If you 
want to include all the items with zero values, check the Zero items check box. 
 
Lastly, you can include one or more avoidable factor grades in the list. Use the drop-down list to 
select Possible cause, Probable cause or All grades. (A default can be set on the Program setup window.) 
 
Data analysis 
 
This window displays its data on two tabs. The Data tab is visible when the window opens, 
presenting you with a data table which summarizes the avoidable factors identified with perinatal 
death, ordered from the most to the least common. The total number of perinatal deaths is also 
calculated. 
 
You can use the data filter to specify any subgroup of data you want to include in the analysis. 
See here for a detailed description of the data filter. 
 
The data presented in the table can be transferred to Microsoft Excel by clicking on the Transfer to 

MS Excel button. A new Excel sheet named 'Avoidable factors' will be created. 
 
The Graph tab presents the data as a pie graph. You can display either the groups of avoidable 
factors (headings) or the specific avoidable factors (items). Use the Display drop-down list to select 
either Headings or Items, then click on the Update graph button. 
 
The pie can consist of up to ten 'slices', each representing a heading or item, and one additional 
'slice' grouping all the remaining headings or items as 'Other'. Use the Include top xx headings/items spin 
box to indicate the number of slices you want to be displayed, then click on the Update graph button. 
 
Print the data 
 
To print the table or graph, click on the Print button. The print preview will be displayed, ready to 
print the report. 
 
Close 
 
Click on the Close button to close this window. Depending on your program setup, the window will 
also close when the Data analysis toolbar is closed.  
 
 
List avoidable factors – Data filter 
 
By using a data filter, PPIP allows the analysis of subgroups of data when creating the list of 
avoidable factors. 
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When the Avoidable factors associated with perinatal deaths window opens, avoidable 
factors identified in all perinatal deaths within the specified dates are included in the list. To switch 
to the filter view, click on the Set up filters button. You will be presented with a list of possible data 
filters, all initially disabled, i.e. Select all is checked. Uncheck a specific filter's Select all check box to 
enable it and to proceed to identify the subgroup to use in the data analysis. 
 
Checking a filter item really tells PPIP to look only at perinatal deaths where the following is true... 
Or, seen in the opposite way,  unchecking an item means all deaths where that particular fact it 
true will be disregarded when the list of avoidable factors is drawn up. 
 
Example: If the birth weight group 500 - 999g is unchecked in the filter setup, all deaths where the 
birth weight was 500g to 999g will be ignored when PPIP goes through the data to create the 
data table. 
 
The following filters are available: 
•  Time of perinatal death 
 You can include or exclude neonates who were:  
•  Early neonatal deaths  
•  Late neonatal deaths  
•  Macerated stillborn  
•  Stillborn, alive on admission  
•  Fresh stillborn, dead on admission  
•  Fresh stillborn, admission status unknown 
  
Check Include all to disregard this item and therefore include all deaths irrespective of the baby's 
condition at birth. 
•  Birth weight 
 You can specify the birth weight categories you want to include or exclude, or you can include 
specific birth weights by checking the Specify check box and entering a minimum and maximum 
birth weight to include. 
 
Check Include all to disregard this item and therefore include all deaths irrespective of the baby's 
birth weight. 
•  Place of birth 
 You can include or exclude neonates who were born:  

•  At this unit  
•  At home  
•  In transit  
•  At another unit  
•  At an unknown place 
  
Check Include all to disregard this item and therefore include all deaths irrespective of the 
baby's place of birth. 

•  Maternal syphilis serology 
 You can include or exclude deaths where the maternal syphilis serology was:  

•  Positive  
•  Negative  

 
 

57 

•  Not done  



The Perinatal Problem Identification Program v2.1 
 
 

•  Done, but the result not available 
  
Check Include all to disregard this item and therefore include all deaths irrespective of the 
maternal syphilis serology. 

•  Maternal HIV serology 
 You can include or exclude deaths where the maternal HIV serology was:  

•  Positive  
•  Negative  
•  Not done  
•  Done, but the result not available 
  
Check Include all to disregard this item and therefore include all deaths irrespective of the 
maternal HIV serology. 

•  Maternal age 
 You can include only deaths where the maternal age was between specific values. Check 
Unknown to include the perinatal deaths where the maternal age was unknown. 
 
Check Include all to disregard this item and therefore include all deaths irrespective of the maternal 
age. 
•  Antenatal care 
 You can include or exclude perinatal deaths where the mother did, or did not receive antenatal 
care, or where this information was unknown. 
 
Check Include all to disregard this item and therefore include all deaths irrespective of the antenatal 
care. 
•  Number of infants 
 You can include only singleton or only multiple pregnancies. 
 
Check Include all to disregard this item and therefore include both singleton and multiple 
pregnancies. 
•  Primary cause of perinatal death 
 You can include only neonatal deaths where a specific primary obstetric cause of perinatal death 
was identified. Use the drop-down list to select the primary cause to use as filter. 
 
If you select a specific primary cause of death, only neonatal deaths where this cause was 
identified will be analyzed. If you select a heading, all the specific causes of death under the 
heading will be included. 
 
Check Include all to disregard this item and therefore include all primary causes of perinatal death. 
•  Final cause of neonatal death 
 You can include only perinatal deaths where a specific final cause of neonatal death was 
identified. Use the drop-down list to select the final cause to use as filter. 
 
If you select a specific final cause of death, only perinatal deaths where this cause was identified 
will be analyzed. If you select a heading, all the specific causes of death under the heading will be 
included. 
 
Check Include all to disregard this item and therefore include all final causes of neonatal death. 
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Once you have set up the filters you want to use, click on the Apply filters button to return to the data 
table. The filters you have set up will be indicated with a check , while the inactive filters are 
marked with a cross . The number of perinatal deaths which meet the filter criteria will also be 
displayed.  
 

 
Monthly avoidable mortality rate 
 
Getting to it 
 
To open the Influence of avoidable factors on Mortality Rates data analysis window, open 
the Data analysis toolbar, then click on the Avoidable factors toggle button, which will show the relevant 
data function buttons. The Avoidable mortality button will open the data analysis window. 
 
Screen controls 
 
You can define the data to be included in this analysis by setting the following: 
•  Data period 
 Use the drop-down list to specify the number of months / years to include in the graph. If you 
have previously specified a default data period for time graphs in your program setup, this will be 
used when the window opens. If no default data period has been set, the last six months' data will 
be displayed in the graph. 
 
You can display six months, one year, two years, five years or all data in the time graph. 
•  Data used 
 Because detailed Perinatal death data is used to create this data graph, this will always be set to 
Detailed perinatal death data and the drop-down list will be disabled. 
•  Calculation method 
 Use the drop-down list to indicate whether you want data only from the currently selected data 
set to be included in the analysis (Own data only), or this data set and all those below it in the data 
pyramid (Cumulative data). 
 
If your data pyramid setup does not show any data sets below the currently selected data set, this 
drop-down list will be disabled, and Own data only will always be selected. 
•  Mortality rate 
 Use the drop-down list to select the mortality rate to be calculated - either the Perinatal mortality 
rate or the Neonatal mortality rate can be used in the graph. 
•  Display 
 Use the drop-down list to select whether the actual mortality rates for each month or a 3-month 
moving average of the rates should be displayed in the graph. 
•  Include grade 
 Use the drop-down list to select whether PPIP should include avoidable factors graded 'Probable 
cause' only, or those graded 'Possible cause' only, or all avoidable factors, irrespective of the 
grading. 
•  Scroll buttons 
 The First data button will scroll the graph all the way back to the first month for which data was 
entered. 
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The Back half screen button will scroll back the graph half a screen, i.e. it will move the graph back in 
time 50% of the Data period currently being displayed. 
 
The Forward half screen button will scroll the graph forward half a screen, i.e. it will move the graph 
forward in time 50% of the Data period currently being displayed. 
 
The Last data button will scroll the graph all the way forward to the last month for which data was 
entered. 
•  Include data 
 When the window opens, births in all five birth weight groups are included in the mortality rate 
displayed in the graph. By checking or unchecking the birth weight check boxes, you can select 
which birth weight groups to include in the calculation. 
 
Data analysis 
 
This window displays its data on two tabs. The Graph tab is displayed when the window opens. 
The graph displays three values. A solid (filled) line graph (blue) represents the actual mortality 
rate for a given month, a green line represents the mortality rate where no avoidable factors were 
identified, while a red line graph represents the mortality rate where avoidable factors were 
identified. 
 
The Data tab displays the data presented in the graph. When the window opens, the data will be 
sorted according to date, starting at the oldest entries. This sort order can be reversed to show 
the most recent data at the top of the table. To reverse the sort order, click on the Reverse sort order 

button. 
 
The data presented in the table can be transferred to Microsoft Excel by clicking on the Transfer to 

MS Excel button. A new Excel sheet named 'Avoidable mortality rate' will be created. 
 
Print the data 
 
To print the graph or data, click on the Print button. The print preview will be displayed, ready to 
print the report. 
 
Close 
 
Click on the Close button to close this window. Depending on your program setup, the window will 
also close when the Data analysis toolbar is closed.  
 
 
 
Monthly avoidable percentage 
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Getting to it 
 
To open the Avoidable factors as percentage of all deaths data analysis window, open the 
Data analysis toolbar, then click on the Avoidable factors toggle button, which will show the relevant data 
function buttons. The Percentage avoidable factors button will open the data analysis window. 
 
Screen controls 
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You can define the data to be included in this analysis by setting the following: 
•  Data period 
 Use the drop-down list to specify the number of months / years to include in the graph. If you 
have previously specified a default data period for time graphs in your program setup, this will be 
used when the window opens. If no default data period has been set, the last six months' data will 
be displayed in the graph. 
 
You can display six months, one year, two years, five years or all data in the time graph. 
•  Data used 
 Because detailed Perinatal death data is used to create this data graph, this will always be set to 
Detailed perinatal death data and the drop-down list will be disabled. 
•  Calculation method 
 Use the drop-down list to indicate whether you want data only from the currently selected data 
set to be included in the analysis (Own data only), or this data set and all those below it in the data 
pyramid (Cumulative data). 
 
If your data pyramid setup does not show any data sets below the currently selected data set, this 
drop-down list will be disabled, and Own data only will always be selected. 
•  Deaths 
 Use the drop-down list to select the deaths to be included in this analysis - either All perinatal deaths, 
or Neonatal deaths can be used in the graph. 
•  Number of avoidable factors 
 Use the drop-down list to select the number of avoidable factors a death must have to be 
included in the analysis - you can select deaths with One or more, Two or more, Three or more, Four or more 

or Five avoidable factors. 
•  Include grade 
 Use the drop-down list to select whether PPIP should include avoidable factors graded 'Probable 

cause' only, or those graded 'Possible cause' only, or all avoidable factors, irrespective of the grading. 
•  Scroll buttons 
 The First data button will scroll the graph all the way back to the first month for which data was 
entered. 
 
The Back half screen button will scroll back the graph half a screen, i.e. it will move the graph back in 
time 50% of the Data period currently being displayed. 
 
The Forward half screen button will scroll the graph forward half a screen, i.e. it will move the graph 
forward in time 50% of the Data period currently being displayed. 
 
The Last data button will scroll the graph all the way forward to the last month for which data was 
entered. 
•  Include data 
 When the window opens, births in all five birth weight groups are included in the mortality rate 
displayed in the graph. By checking or unchecking the birth weight check boxes, you can select 
which birth weight groups to include in the calculation. 
•  Display 
 The graph consists of two parts. A bar graph (red) represents the actual percentage of deaths 
during a given month where the selected number and grade of avoidable factors were identified, 
while a line graph (blue) represents the three-month moving average of the actual values. Either 
of these or both can be displayed by checking or unchecking the Actual percentage and 3-month moving 

average check boxes. 
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Data analysis 
 
This window displays its data on two tabs. The Graph tab is displayed when the window opens, 
consisting of red bars representing the actual percentage of deaths during a given month where 
the selected number and grade of avoidable factors were identified, and a blue line representing 
the three-month moving average of the values. 
 
The Data tab displays the data presented in the graph. When the window opens, the data will be 
sorted according to date, starting at the oldest entries. This sort order can be reversed to show 
the most recent data at the top of the table. To reverse the sort order, click on the Reverse sort order 

button. 
 
 
The data presented in the table can be transferred to Microsoft Excel by clicking on the Transfer to 

MS Excel button. A new Excel sheet named 'Avoidable mortality rate' will be created. 
 
Print the data 
 
To print the graph or data, click on the Print button. The print preview will be displayed, ready to 
print the report. 
 
Close 
 
Click on the Close button to close this window. Depending on your program setup, the window will 
also close when the Data analysis toolbar is closed.  
 
 
 
Primary cause of maternal death 
 
Getting to it 
 
To open the Primary obstetric cause of maternal death data analysis window, open the Data 

analysis toolbar, then click on the Maternal deaths toggle button, which will show the relevant data 
function buttons. The Primary causes button will open the data analysis window. 
 
Screen controls 
 
You can define the data to be included in this analysis by setting the following: 
•  Dates included 
 Use the drop-down lists and spin boxes to enter the months to include in the table. If you have 
previously selected default data analysis dates, these dates will be included when this window 
opens. If no default dates have been set, all data will be included in the table. 
•  Data used 
 Because detailed Maternal death data is used to create this data table, this will always be set to 
Maternal death data and the drop-down list will be disabled. 
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•  Calculation method 
 Use the drop-down list to indicate whether you want data only from the currently selected data 
set to be included in the analysis (Own data only), or this data set and all those below it in the data 
pyramid (Cumulative data). 
 
If your data pyramid setup does not show any data sets below the currently selected data set, this 
drop-down list will be disabled, and Own data only will always be selected. 
•  Display 
 By default the data table displays group headings as well as the individual sub-items under these 
headings. You can display either or both of these by checking or unchecking the Headings and Items 

check boxes. 
 
If no deaths were recorded due to a specific cause, the particular item will not be displayed. If you 
want to include all the items with zero values, check the Zero items check box. 
 
Data analysis 
 
This window displays its data on two tabs. The Data tab is visible when the window opens, 
presenting you with a data table which summarizes the primary obstetric causes of maternal 
death, ordered from the most to the least common. The total number of maternal deaths is also 
calculated. 
 
When the window opens, all maternal deaths within the specified dates are included in the list. 
You can use the single data filter to specify a subgroup of data you want to include in the 
analysis. The data filter is initially disabled, i.e. Include all is checked. Uncheck the filter's Include all 

check box to enable it and then proceed to identify the subgroup to use in the data analysis. 
 
Checking a filter item really tells PPIP to look only at maternal deaths where the following is true... 
Or, seen in the opposite way,  unchecking an item means all deaths where that particular fact it 
true will be disregarded when the list of causes of death is drawn up. 
 
The following filter is available: 
•  Death occurred 
 You can include or exclude women who died:  

•  During early pregnancy  
•  In the antenatal period  
•  Intrapartum  
•  Postpartum  
•  Unknown 
  

As soon as you check or uncheck a filter element, the data analysis will be repeated and the list 
of causes updated. 
 
The number of maternal deaths which meet the filter criteria are also displayed. 
 
The data presented in the table can be transferred to Microsoft Excel by clicking on the Transfer to 

MS Excel button. A new Excel sheet named 'Primary causes Maternal death' will be created. 
 
The Graph tab presents the data as a pie graph. You can display either the groups of causes 
(headings) or the specific causes of death (items). Use the Display drop-down list to select either 
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Headings or Items, then click on the Update graph button. 
 
The pie can consist of up to ten 'slices', each representing a heading or item, and one additional 
'slice' grouping all the remaining headings or items as 'Other'. Use the Include top xx headings/items spin 
box to indicate the number of slices you want to be displayed, then click on the Update graph button. 
 
Print the data 
 
To print the table or graph, click on the Print button. The print preview will be displayed, ready to 
print the report. 
 
Close 
 
Click on the Close button to close this window. Depending on your program setup, the window will 
also close when the Data analysis toolbar is closed.  
 
 
 
Final cause of maternal death 
 
Getting to it 
 
To open the Final cause of maternal death data analysis window, open the Data analysis toolbar, 
then click on the Maternal deaths toggle button, which will show the relevant data function buttons. 
The Final causes button will open the data analysis window. 
 
Screen controls 
 
You can define the data to be included in this analysis by setting the following: 
•  Dates included 
 Use the drop-down lists and spin boxes to enter the months to include in the table. If you have 
previously selected default data analysis dates, these dates will be included when this window 
opens. If no default dates have been set, all data will be included in the table. 
•  Data used 
 Because detailed Maternal death data is used to create this data table, this will always be set to 
Maternal death data and the drop-down list will be disabled. 
•  Calculation method 
 Use the drop-down list to indicate whether you want data only from the currently selected data 
set to be included in the analysis (Own data only), or this data set and all those below it in the data 
pyramid (Cumulative data). 
 
If your data pyramid setup does not show any data sets below the currently selected data set, this 
drop-down list will be disabled, and Own data only will always be selected. 
•  Display 
 By default the data table displays group headings as well as the individual sub-items under these 
headings. You can display either or both of these by checking or unchecking the Headings and Items 

check boxes. 
 
If no deaths were recorded due to a specific cause, the particular item will not be displayed. If you 
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want to include all the items with zero values, check the Zero items check box. 
 
Data analysis 
 
This window displays its data on two tabs. The Data tab is visible when the window opens, 
presenting you with a data table which summarizes the final causes of maternal death, ordered 
from the most to the least common. The total number of maternal deaths is also calculated. 
 
When the window opens, all maternal deaths within the specified dates are included in the list. 
You can use the single data filter to specify a subgroup of data you want to include in the 
analysis. The data filter is initially disabled, i.e. Include all is checked. Uncheck the filter's Include all 

check box to enable it and then proceed to identify the subgroup to use in the data analysis. 
 
Checking a filter item really tells PPIP to look only at maternal deaths where the following is true... 
Or, seen in the opposite way,  unchecking an item means all deaths where that particular fact it 
true will be disregarded when the list of causes of death is drawn up. 
 
The following filter is available: 
•  Death occurred 
 You can include or exclude women who died:  

•  During early pregnancy  
•  In the antenatal period  
•  Intrapartum  
•  Postpartum  
•  Unknown 
 

 As soon as you check or uncheck a filter element, the data analysis will be repeated and the list 
of causes updated. 
 
The number of maternal deaths which meet the filter criteria are also displayed. 
 
The data presented in the table can be transferred to Microsoft Excel by clicking on the Transfer to 

MS Excel button. A new Excel sheet named 'Final causes Maternal death' will be created. 
 
The Graph tab presents the data as a pie graph. You can display either the groups of causes 
(headings) or the specific causes of death (items). Use the Display drop-down list to select either 
Headings or Items, then click on the Update graph button. 
 
The pie can consist of up to ten 'slices', each representing a heading or item, and one additional 
'slice' grouping all the remaining headings or items as 'Other'. Use the Include top xx headings/items spin 
box to indicate the number of slices you want to be displayed, then click on the Update graph button. 
 
Print the data 
 
To print the table or graph, click on the Print button. The print preview will be displayed, ready to 
print the report. 
 
Close 
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Click on the Close button to close this window. Depending on your program setup, the window will 
also close when the Data analysis toolbar is closed.  
 
 
Maternal mortality rate & ratios 
 
Getting to it 
 
To open the Maternal death rates & ratios data analysis window, open the Data analysis toolbar, 
then click on the Maternal deaths toggle button, which will show the relevant data function buttons. 
The Mortality rate + ratios button will open the data analysis window. 
 
Screen controls 
 
You can define the data to be included in this analysis by setting the following: 
•  Dates included 
 Use the drop-down lists and spin boxes to enter the months to include in the table. If you have 
previously selected default data analysis dates, these dates will be included when this window 
opens. If no default dates have been set, all data will be included in the table. 
•  Data used 
 Because detailed Maternal death data is used to create this data table, this will always be set to 
Maternal death data and the drop-down list will be disabled. 
•  Calculation method 
 Use the drop-down list to indicate whether you want data only from the currently selected data 
set to be included in the analysis (Own data only), or this data set and all those below it in the data 
pyramid (Cumulative data). 
 
If your data pyramid setup does not show any data sets below the currently selected data set, this 
drop-down list will be disabled, and Own data only will always be selected. 
 
Data analysis 
 
This window displays the following analyses: 
•  Maternal mortality ratio using all births  
•  Maternal mortality ratio using live births only  
•  Maternal mortality rate (If the number of women of reproductive age is not known, this rate will 
not be calculated.)  
•  Total number of maternal deaths identified 
  
Click on the Information on calculation of rates and ratios button to view information on how these rates and 
ratios are calculated and to edit your population's number of women of reproductive age. 
 
Print the data 
 
To print the data, click on the Print button. If you have not set up a default report, you will be able 
to select which rates or ratios to print, after which the print preview will be displayed, ready to 
print the report. 
 
Close 
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Click on the Close button to close this window. Depending on your program setup, the window will 
also close when the Data analysis toolbar is closed.  
 
 
Define report - Maternal mortality rate & ratios 
 
Select the parts of the report you want to include in the printout. 
 
If you always want to print the same part(s) of this report, select the part(s) of the report to be 
printed, then check the Use this as default, then don't ask me again check box. This default setup can be 
changed in the Program setup window. 
 
Click on the Print button to preview the printout and print it. 
 
Click on the Cancel printing button to close this window without printing the report.  
 
 
 
Information on calculation of rates & ratios 
 
The Maternal mortality rates & ratios screen shows you how the maternal mortality ratios 
and the maternal mortality rate are calculated. It also allows you to enter the number of women of 
reproductive age (15 - 49yrs) in your population, as this is used as denominator when calculating 
the maternal mortality rate. 
 
This information can also be entered on the Program setup window - see here for more 
information.  
 
 
 
Unprocessed maternal death data 
 
Getting to it 
 
To open the Unprocessed Maternal Death data data analysis window, open the Data analysis 

toolbar, then click on the Maternal deaths toggle button, which will show the relevant data function 
buttons. The Unprocessed data button will open the data analysis window. 
 
Screen controls 
 
You can define the data to be included in this table by setting the following: 
•  Dates included 
 Use the drop-down lists and spin boxes to enter the months to include in the table. If you have 
previously selected default data analysis dates, these dates will be included when this window 
opens. If no default dates have been set, all data will be included in the table. 

 
 

67 

•  Data used 
 Because detailed Maternal death data is used to create this data table, this will always be set to 
Maternal death data and the drop-down list will be disabled. 
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•  Calculation method 
 Use the drop-down list to indicate whether you want data only from the currently selected data 
set to be included in the analysis (Own data only), or this data set and all those below it in the data 
pyramid (Cumulative data). 
 
If your data pyramid setup does not show any data sets below the currently selected data set, this 
drop-down list will be disabled, and Own data only will always be selected. 
•  Reverse sort order 
 When the window opens, the data will be sorted according to date, starting at the oldest entries. 
This sort order can be reversed to show the most recent data at the top of the table. To reverse 
the sort order, click on the Reverse sort order button. 
 
Data analysis 
 
This table displays the following data fields contained in the Maternal Death data file: 
•  User ID  
•  Death date  
•  Part of pregnancy during which the death occurred  
•  Obstetric cause of death  
•  Three final (contributing) causes of death 
  
The data is presented as it appears in the data file - no data manipulation takes place. 
 
The data presented in the table can be transferred to Microsoft Excel by clicking on the Transfer to 

MS Excel button. A new Excel sheet named 'Maternal deaths Raw data' will be created. 
 
 
Print the data 
 
To print the data table, click on the Print button. The print preview will be displayed, ready to print 
the report. 
 
Close 
 
Click on the Close button to close this window. Depending on your program setup, the window will 
also close when the Data analysis toolbar is closed.  
 

 
Mode of delivery 
 
Getting to it 
 
To open the Mode of delivery data analysis window, open the Data analysis toolbar, then click on the 
Miscellaneous toggle button, which will show the relevant data function buttons. The Mode of delivery 

button will open the data analysis window. 
 
Screen controls 
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You can define the data to be included in this analysis by setting the following: 
•  Dates included 
 Use the drop-down lists and spin boxes to enter the months to include in the table. If you have 
previously selected default data analysis dates, these dates will be included when this window 
opens. If no default dates have been set, all data will be included in the table. 
•  Data used 
 Because only Monthly data is used to create this table, this will always be set to Total delivery data 

and the drop-down list will be disabled. 
•  Calculation method 
 Use the drop-down list to indicate whether you want data only from the currently selected data 
set to be included in the analysis (Own data only), or this data set and all those below it in the data 
pyramid (Cumulative data). 
 
If your data pyramid setup does not show any data sets below the currently selected data set, this 
drop-down list will be disabled, and Own data only will always be selected. 
 
Data analysis 
 
This window displays its data on two tabs. The Data tab is displayed when the window opens, 
displaying a breakdown of the following delivery methods: 
•  Normal vaginal delivery  
•  Ventouse delivery  
•  Forceps delivery  
•  Assisted delivery - Unknown (This category reflects data entered with PPIP version 1, which 
did not distinguish between ventouse and forceps deliveries)  
•  Vaginal breech delivery  
•  Caesarean section  
•  Unknown delivery method 
  
The data presented in the table can be transferred to Microsoft Excel by clicking on the Transfer to 

MS Excel button. A new Excel sheet named 'Delivery method' will be created. 
 
The Graphs tab displays a pie graph representing the different methods of delivery. 
 
Print the data 
 
To print the graph or data, click on the Print button. The print preview will be displayed, ready to 
print the report. 
 
Close 
 
Click on the Close button to close this window. Depending on your program setup, the window will 
also close when the Data analysis toolbar is closed.  
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Other miscellaneous data 
 
Getting to it 
 
To open the Other miscellaneous data data analysis window, open the Data analysis toolbar, then 
click on the Miscellaneous toggle button, which will show the relevant data function buttons. The Other 

button will open the data analysis window. 
 
Screen controls 
 
You can define the data to be included in this analysis by setting the following: 
•  Dates included 
 Use the drop-down lists and spin boxes to enter the months to include in the table. If you have 
previously selected default data analysis dates, these dates will be included when this window 
opens. If no default dates have been set, all data will be included in the table. 
•  Data used 
 Because only Monthly data is used in this analysis, this will always be set to Total delivery data and 
the drop-down list will be disabled. 
•  Calculation method 
 Use the drop-down list to indicate whether you want data only from the currently selected data 
set to be included in the analysis (Own data only), or this data set and all those below it in the data 
pyramid (Cumulative data). 
 
If your data pyramid setup does not show any data sets below the currently selected data set, this 
drop-down list will be disabled, and Own data only will always be selected. 
 
Data analysis 
 
This window displays its data on six tabs: 
•  Multiple pregnancies 
 This tab displays:  

•  Total number of multiple pregnancies, and percentage of all pregnancies.  
•  Total number of babies born from multiple pregnancies, and percentage of all infants 
born. 
   

•  Antenatal care 
 This tab displays:  

•  Number of women receiving antenatal care at a local clinic  
•  Number of women receiving antenatal care elsewhere  
•  Number of women receiving no antenatal care  
•  Unknown 

   
•  Syphilis serology 
 This tab displays:  

•  Number of women with positive syphilis serology  
•  Number of women with negative syphilis serology  
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•  Number of women with unknown syphilis serology 
 These are the number reported with Monthly data. 
 
The data presented in the table can be transferred to Microsoft Excel by clicking on the Transfer to 

MS Excel button. A new Excel sheet named 'Maternal syphilis serology' will be created. 
•  HIV serology 
 This tab displays:  

•  Number of women with positive HIV serology  
•  Number of women with negative HIV serology  
•  Number of women with unknown HIV serology 

 These are the number reported with Monthly data. 
 
The data presented in the table can be transferred to Microsoft Excel by clicking on the Transfer to 

MS Excel button. A new Excel sheet named 'Maternal HIV serology' will be created. 
•  Anti-retroviral therapy 
 This tab displays:  

•  Number of women with positive HIV serology  
•  Number of HIV-positive women who received anti-retroviral therapy, also reported as 
percentage of all births and percentage of HIV-positive women 
•  Number of HIV-positive women who did not receive anti-retroviral therapy, also 
reported as percentage of all births and percentage of HIV-positive women. 
•  Number of HIV-positive women for whom information about anti-retroviral therapy was 
unknown, also reported as percentage of all births and percentage of HIV-positive 
women. 
 

These are the number reported with Monthly data. 
 
The data presented in the table can be transferred to Microsoft Excel by clicking on the Transfer to 

MS Excel button. A new Excel sheet named ‘Anti-retroviral therapy’ will be created. 
•  Maternal age 
 This tab displays:  

•  The number of women younger than 18 years of age delivered  
•  The number of women 18 to 19 years of age delivered  
•  The number of women older than 34 years of age delivered 

   
•  Born before arrival 
 This tab displays:  

•  The number of women delivered before arrival at the health care facility. 
  
Print the data 
 
To print the data, click on the Print button. The print preview will be displayed, ready to print the 
report. 
 
Close 
 
Click on the Close button to close this window. Depending on your program setup, the window will 
also close when the Data analysis toolbar is closed.  
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Predefined monthly report 
 
You can set up and print a summary of monthly data for easy reporting of basic data. 
 
To define which fields you want to include in the report, select Tools -> Program settings... 
from the Main menu. Open the Monthly report Tab, and use the check boxes to select the data fields 
you want to include in the report. The following data fields can be selected: 
•  Table containing total births 
 This will include a summary of total deliveries, early neonatal deaths, late neonatal deaths and 
stillbirths in the report. 
•  Number of multiple pregnancies 
 This will include the number of multiple pregnancies and neonates born from multiple 
pregnancies. 
•  Antenatal care summary 
 Check this to include a summary of antenatal care data. 
•  Born Before Arrival 
 This will include the number of babies born before arrival to the health care institution. 
•  Method of delivery summary 
 Check this to include a table of delivery methods. 
•  Syphilis serology summary 
 Check this to include a summary of maternal syphilis serology. 
•  HIV serology summary 
 This will include a summary of maternal HIV serology. 
•  Maternal age summary 
 Check this to report on deliveries by teenagers and women older than 34 years of age. 
 
You must also select the data to be used when reporting on perinatal and neonatal deaths. You 
can either Use data entered with total deliveries, or Use perinatal deaths for which detailed data was entered. See here 
for a discussion of perinatal and neonatal death data entered with monthly data. 
 
Once your default report has been defined, select Data analysis -> Print Monthly Totals 
report from the Main menu. You will be prompted to indicate which month you want to report on, 
after which the report preview will be displayed, ready to be printed.  
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Data transfer 
 

Import PPIP v1 data 
 
If you have been using the first Windows version of PPIP, you must import your original data to 
be able to use it in PPIP v2. To open the PPIP v1 upgrade wizard, select File -> Import 
data -> Import version 1 data from the Main menu. The wizard automates the process for 
you by allowing you to define exactly how the data import should proceed, and then writing the 
existing data to your new data file, changing it to the correct format and entering default where 
selected. 
 
The following list describes all possible wizard steps. Because the wizard will only present you 
with the relevant steps, depending on your input, you may not see all these as you go through the 
process. 
 
On all steps, click on the Next button to proceed to the next step, or click on the Previous button to go 
back to the previous step. 
 
Once the wizard has asked all its questions, click on the Import button to start the process. Once 
you have done this, you cannot cancel the process, and you have to wait for it to complete before 
you will have control of the wizard again. 
 
•  Welcome to the PPIP data upgrade wizard 
 You are presented with some background information about the data upgrade (import) process. 
•  Existing unit 
 Select the data to be imported. As indicated on the screen, in PPIP v1 the file containing the 
name of the unit was named Clinic.tps. Use the File lookup button to navigate to the correct file. 
•  Duplicate unit name 
 You will see this step only if a data set with the same name as that of the data set you want to 
import, already exists in your data file. You can Rename the unit about to be upgraded or Select a different data 

file to import. 
•  Select files to convert 
 The wizard will determine which data is available in the data set you have selected. These will be 
presented to you, to indicate which part(s) should be imported. Use the check boxes to indicate 
whether you want to import Total births (this will use the v1 file Births.tps), Perinatal deaths (this will use 
the v1 files P_Deaths.tps and SelectAv.tps) and Maternal deaths (this will use the v1 file 
M_Deaths.tps). 
•  Unit detail (Clinic.tps) 
 In the current version, you can describe the data set in more detail. Supply the detail here by 
entering the Health district and Health region, then select the Level of care from the drop-down list. You 
must also define this data set's position in your data pyramid. If you want to position the new data 
set below an existing unit, select it from the Assign to higher unit drop-down list. 
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•  Total births (Births.tps) 
 A description of changes to the data file setup is provided. If you prefer to see every data entry 
(data for one month) and manually enter the changed data, check the Show me every month's data - I'll 

update manually check box. 
 
If you are importing a large data file, manual update will take a very long time. Because you 
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cannot stop this process without putting your data file at risk, be sure that you really want to go 
through every month before you proceed. 
 
If you choose not to do the file update manually, the next page will inform you about the changes 
the wizard will make to your file. 
•  Perinatal deaths (P_Deaths.tps and SelectAv.tps) 
 A description of changes to the data file setup is provided. If you prefer to see every data entry 
(data for one perinatal death) and manually enter the changed data, check the Show me every month's 

data - I'll update manually check box. 
 
If you are importing a large data file, manual update will take a very long time. Because you 
cannot stop this process without putting your data file at risk, be sure that you really want to go 
through every month before you proceed. 
 
If you choose not to do the file update manually, the next page will inform you about the changes 
the wizard will make to your file. 
•  Maternal deaths (M_Deaths.tps) 
 A description of changes to the data file setup is provided. If you prefer to see every data entry 
(data for one maternal death) and manually enter the changed data, check the Show me every month's 

data - I'll update manually check box. 
 
If you are importing a large data file, manual update will take a very long time. Because you 
cannot stop this process without putting your data file at risk, be sure that you really want to go 
through every month before you proceed. 
 
If you choose not to do the file update manually, the next page will inform you about the changes 
the wizard will make to your file. 
•  Ready to convert 
 A message is displayed before the final import process to give you a chance to change your 
settings. 
•  Total births manual conversion 
 The wizard will take you through all the monthly data, displaying data for one month at a time. All 
the fields not included in PPIP v1 are displayed. Enter the correct data, then click on the Done 
button. After the last month's data, the wizard will move on to the next page. 
•  Total births conversion 
 While the wizard automatically updates your data file, you will be informed about its progress. 
•  Perinatal deaths manual conversion 
 The wizard will take you through all the perinatal deaths, displaying data for one death at a time. 
All the fields not included in PPIP v1 are displayed. Enter the correct data, then click on the Done 
button. After the last perinatal death's data, the wizard will move on to the next page. 
•  Perinatal deaths conversion 
 While the wizard automatically updates your data file, you will be informed about its progress. 
•  Maternal deaths manual conversion 
 The wizard will take you through all the maternal deaths, displaying data for one death at a time. 
The field not included in PPIP v1 is displayed. Enter the correct data, then click on the Done 
button. After the last maternal death's data, the wizard will move on to the next page. 
•  Maternal deaths conversion 
 While the wizard automatically updates your data file, you will be informed about its progress. 
•  Done! 
 After the process has been completed, you can either close the wizard, or restart the wizard.  
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Import v1 data - inconsistent data 
 
The Inconsistent data table displays the months during which more perinatal deaths were 
entered in a specific weight category than the number of deliveries recorded in the same weight 
category. It implies that for these months, the mortality rate was more than 100%! 
 
Click on the Print button to print a copy of the table. This enables you to go through your data to 
correct it. 
 
Click on the Close button to close the window  
 
 
 
Import data file 
 
 If you receive an exported data file from another PPIP user, and you want to make this data part 
of your data file, you have to import it. To open the PPIP data import wizard, select File -> 
Import data -> Import PPIP v2 data file from the Main menu. The wizard automates the 
process for you by allowing you to define exactly how the data import should proceed, and then 
adding the new data to your existing data file. 
 
The following list describes all possible wizard steps. Because the wizard will only present you 
with the relevant steps, depending on your input, you may not see all these pages as you go 
through the process. 
 
On all steps, click on the Next button to proceed to the next step, or click on the Previous button to go 
back to the previous step. 
 
Once the wizard has asked all its questions, click on the Import button to start the process. Once 
you have done this, you cannot cancel the process, and you have to wait for it to complete before 
you will have control of the wizard again. 
 
•  Welcome to the PPIP data import wizard 
 You are presented with some background information about the data import process. 
•  Select data file 
 You now have to select which exported data file you want the wizard to use. Click on the Select 

folder button and navigate to the folder containing the file. Make sure the name of the file is 
displayed in the File name entry box, then click on the Open button. 
•  Select the unit to import 
 A list of exported data sets is displayed. When you select a data set, a message will appear 
below the list, indicating whether the exported file also contains data for this unit. (If only the unit 
name was exported, with no accompanying data, you can still import the unit detail.) This will 
create an empty data file for this unit. 
 
Although the original data pyramid structure of the exported data is maintained, you can only 
import one unit at a time. This protects the integrity of your data pyramid by preventing you from 
importing duplicate lower level units that may already exist somewhere in your data pyramid. 
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•  Select data to import 
 Use the check boxes to indicate which part(s) of the data file you want to import. You can import 
Total births, Perinatal deaths and Maternal deaths, depending on whether these were originally 
included in the exported data file. You can also import all data, or only data for selected dates. If 
you want to enter specific dates, select the Selected dates radio buttons, then use the drop-down lists 
and spin boxes to define the dates. 
•  Existing data management 
 There are two situations where you may be warned about similar data on your system: 
•  A data set with the same name as the one you are importing already exists in your current data 
file. This will happen, for instance, if you have previously imported data from this unit, and you are 
now importing more recent data from the same unit. You will be given three options: 
  
- Delete the existing data 
Select this if you want to discard the existing data, and only want to have the new imported data 
for this unit. The imported data replaces your existing data. 
 
All existing data in this data set will be deleted, NOT only the duplicates. 
 
- Merge all data, prompt for new ID for duplicates 
Select this to add the imported data to your existing data. Monthly data will be added to your 
existing data if data for the particular months already exist. Perinatal and maternal deaths will be 
added, but you will be prompted to supply new identification detail if any duplicate identification 
numbers are found.  
 
You will now import EVERYTHING in the new data file, even if a perinatal or maternal death with 
the same ID already exists - you will have to supply new ID's for these deaths, but you cannot 
skip any of them. 
 
- Merge all data, do not import duplicates 
Select this to add only data that doesn't already exist in your data set. If monthly data is 
encountered for a month for which data already exists, the imported data will be ignored. Any 
perinatal and maternal deaths with ID's already used in your current data set will NOT be 
imported. New months and new deaths will be added to your current data. 
•  A data set with the same name as the one you are importing previously existed in your data 
file, but was subsequently deleted. When the data set was deleted, the user elected NOT to 
remove its data as well. Therefore, although the data still remained on disk, you cannot see it in 
PPIP, because you cannot open the data set any more. You now have the following options: 
  
- Delete the existing data 
Select this if you want to discard the existing data, and only want to have the new imported data 
for this unit. The imported data replaces your existing data. 
 
All existing data will be deleted, NOT only the duplicates. 
 
- Change the existing data's unit name 
You will be allowed to enter a new name for the existing (orphaned) data. You will still not be able 
to see this data, though, unless you create a new data set with this name. 
 
- Use the existing data for the imported unit 
This will import the new unit, and the existing (orphaned) data will become part of its data. You 
will again be allowed to merge all data and supply new ID's for duplicate deaths, or merge all data 
but discard duplicates - see the description above. 
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•  Confirm settings 
 A page is displayed with your selections, before the final import process, to give you a chance to 
change your settings. If you are importing a new unit, you can also now place it in your data 
pyramid under the relevant higher level unit, if necessary. Click on the Import button to start the 
process. 
 
Once you have initiated the import process, you cannot cancel it, and you have to wait for it to 
complete before you will have control of the wizard again. 
•  Importing... 
 While the wizard imports your data, you will be informed about its progress. 
•  Done! 
 After the process has been completed, you can either close the wizard, or restart it.  
 
 
 
Import data file - duplicate ID 
 
The wizard has found an existing record with the ID being imported.The New ID for duplicate 
entry window allows you to supply a new ID for the imported perinatal or maternal death. 
 
Enter a new ID, then click on the OK button.  
 
 
 
Export data file 
 
 If you want the user of another copy of PPIP to open and use data generated by your copy of 
PPIP, you can select which data you want to send (export) to a separate data file, which can then 
be imported by the other user. To open the PPIP data export wizard, select File -> Export 
data -> Export as PPIP data file from the Main menu. The wizard automates the process for 
you by allowing you to define exactly how the data export should proceed, and then writing your 
existing data to a new data file. 
 
The following list describes all possible wizard steps. Because the wizard will only present you 
with the relevant steps, depending on your input, you may not see all these pages as you go 
through the process. 
 
On all steps, click on the Next button to proceed to the next step, or click on the Previous button to go 
back to the previous step. 
 
Once the wizard has asked all its questions, click on the Export button to start the process. Once 
you have done this, you cannot cancel the process, and you have to wait for it to complete before 
you will have control of the wizard again. 
 
•  Welcome to the PPIP data export wizard 
 You are presented with some background information about the data export process. 
•  Select the data to export 
 A list of all your data sets is displayed. Click on the data to be included in the exported file. 
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•  Select export method 
 If there are units below the selected data set in your data pyramid, you must indicate whether 
you want to include these lower levels in the exported data file. (If no lower levels exist, some 
options will be unavailable.) Choose one of the following: 
•  Export only data from the selected unit 
 The wizard will not include any data other than for the selected unit. No lower levels will be 
included. 
•  Include lower levels - keep different units' data separate 
 Data from all the levels below the selected data set will be included in the new data file, and the 
part of the data pyramid reflected in the selection will be carried over to the exported file. This 
means that the user importing the new file will see all the units separately, and can import one or 
more of them. 
•  Include lower levels - merge data under the selected unit's name 
 Data from all the levels below the selected data set will be included in the new data file, but the 
data originally entered for the lower level data sets will be included as if it originated at the 
selected unit. This means that the user importing the new file will see only the selected data set, 
and imports all the data under a single name. 
•  Select data to export 
 Use the check boxes to indicate which part(s) of the data file you want to export. You can export 
Total births, Perinatal deaths and Maternal deaths. You can also export all data, or only data for 
selected dates. If you want to enter specific dates, select the Selected dates radio buttons, then use 
the drop-down lists and spin boxes to define the dates. 
•  Select folder for new data file 
 You now have to name the file you want to create, and indicate where you want to save it. Click 
on the Select folder button and navigate to the folder to which you want to save the file. Enter the 
name of the new file in the File name entry box, using the extension .tps. (If you do not enter the 
extension, the wizard will supply it.) 
 
You can name the new file anything other than the data files PPIP uses to save its data. It is a 
good idea to give it a descriptive name, e.g. the name of the unit being exported. 
•  Confirm export setup 
 A page is displayed with your selections, before the final export process to give you a chance to 
change your settings. Click on the Export button to start the process. 
 
Once you have initiated the export process, you cannot cancel it, and you have to wait for it to 
complete before you will have control of the wizard again. 
•  Exporting... 
 While the wizard exports your data, you will be informed about its progress. 
•  Done! 
 After the process has been completed, you can either close the wizard, or restart it.  
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Backup all data 
 
A very important part of any database is the user's effort to keep the data safe from disaster. 
Every computer hard drive will fail at some stage, so even if you have your computer safeguarded 
from theft, fire, rain, lightening, viruses, worms, hackers and other users, your data is still at risk if 
you don't make regular backups! So, do yourself a favour and design a backup routine according 
to these suggestions. 
 
To open the Backup function, select File -> Backup all data from the Main menu. The backup 
requires an easy one-step process, but may save you lots of heartache. 
 
Click on the Browse button to indicate the drive and folder to which you want to write the backup 
file, and to supply a name for the file. By default, PPIP will write the backup file to the program 
folder and will name it "PPyymmdd" where the last six digits represent today's date. So, a backup 
made on 1 February 2004 will be named "PP040201.zip". You can name the file anything you 
want, but make sure you use a descriptive name. 
 
After you have named the file, click on the Start backup button. You will be informed about the files 
included in the backup. 
 
Once the process is complete, click on the Close button to close the window. 
 
The backup file is written in the standard compressed .zip archive format, and can be 'unzipped' 
or decompressed by any other archiving software, which will again yield the five files included in 
the backup. 
 
In case of a data disaster, use the Restore function in PPIP to restore a previous archive.  
 
 
Backup guidelines 
 
Each user of a data system needs to design a backup strategy that suits his/her way of using the 
software. The frequency and levels of backup depend on the frequency of data updates. Yet, 
these basic guidelines may help you to decide on a backup system that will work for you. 
 
The most important aspect of designing a systematic backup is to keep to the schedule! 
•  Use descriptive file names 
 The only way to know what your backup files contain is to restore them and then open the data 
files. To avoid doing this, make sure to name the files in a way that will allow you to identify the 
date and source (and possibly the level) of the backup. 
•  Rotate your backup media 
 Do not write every subsequent backup to the same disk - if this disk should fail, you will lose all 
your backups. 
•  Create different archive levels 
 Use two rotating sets of archives - one long term and one short term. This means that, 
depending on the frequency of your data entry, you may create a new backup every month, which 
is stored away, and also a backup every week which is rotated in a four-week cycle. So on any 
given day, you will have an archive of your data for the previous month as well as four sets of 
data entered since this archive. In case of a disaster, you will have to redo no more than one 
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week's data entries, or, if that archive fails, two weeks. Even if four weekly archives fail, you will 
always have data no older than one month. Get the picture? 
•  Don't overwrite your last backup 
 As stated above, you must always consider that a disk used for archiving may fail. You may also 
realize after making an archive or two that you have a damaged data file which was carried over 
to the archive - so make sure you use rotating backup sets. 
•  Store your archives in a separate location 
 The worst way of losing data is to diligently make backups, only to have them stolen with your 
computer. Need I say any more? 
 
The most important aspect of designing a systematic backup is to keep to the schedule!  
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Restore archived data 
 
It is hoped that you are reading this part of the Help file out of interest, and not because you have 
had a data disaster. But if you do need to restore a previous archive, aren't you glad you made 
backups!? 
 
To open the Data restore function, select File -> Restore previous backup from the Main 
menu. 
 
Click on the Browse button to select the archive (.zip) file containing your previously backed up 
data. 
 
After you have selected the file, click on the Start restore button. You will be informed about the 
files as they are restored. 
 
If you still have data files in your program folder, these will be overwritten when you do the 
restore! So be sure to back up or move your current files if you still want to keep them. PPIP will 
ask your permission before each file is overwritten. 
 
Once the process is complete, click on the Close button to close the window.  
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Data validity check 
 
If you chose to enter perinatal death numbers with your monthly data (discussed here) as well as 
detailed perinatal death data, PPIP allows you to use the numbers entered with monthly data to 
check whether detail about all deaths were entered. 
 
To open the Data validity check window, select Tools -> Data validity check from the 
Main menu. When this window opens, PPIP will check all dates for which Monthly data was 
entered for the currently selected data set, and will display a table which summarizes any 
discrepancies. 
 
The table displays the particular month, the number of stillbirths, early neonatal deaths and late 
neonatal deaths entered with the Monthly data, and the number of stillbirths, early neonatal 
deaths and late neonatal deaths for which detailed data were entered. It also indicates the birth 
weight categories in which these deaths occurred. 
 
Only months where incorrect or incomplete data seem to have been entered will be included in 
the list. 
 
You can also check selected months only. Select the Selected dates only radio button, then use the 
drop-down lists and spin boxes to enter the first and last month you want to evaluate. Now click 
on the Update button to update the table. 
 
Click on the Print button to print a copy of the table being displayed. A Print preview will be 
displayed, ready to be printed. 
 
Click on the Close button to close the window.  
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Total births update wizard 
 
If you chose NOT to enter perinatal death numbers with your monthly data (discussed here) bit 
you DID enter detailed perinatal death data, or you imported data without perinatal deaths 
number in the monthly data entries, PPIP allows you to use the detailed perinatal death data to 
update the Monthly data file. After this process you will have a Monthly data file which also 
reflects stillbirths and neonatal deaths.  
 
To open the Total births update wizard, select Tools -> Update Total Births file from the 
Main menu. The wizard automates the process for you by allowing you to define exactly how the 
data update should proceed, and then updating the perinatal death data in your existing data file. 
 
The following list describes all possible wizard steps. Because the wizard will only present you 
with the relevant steps, depending on your input, you may not see all these pages as you go 
through the process. 
 
On all steps, click on the Next button to proceed to the next step, or click on the Previous button to go 
back to the previous step. 
 
Once the wizard has asked all its questions, click on the Update button to start the process. Once 
you have done this, you cannot cancel the process, and you have to wait for it to complete before 
you will have control of the wizard again. 
 
•  Welcome to the Total Births update wizard 
 You are presented with some background information about the data update process. 
•  Select dates to update 
 You can also update all data, or only data for selected dates. If you want to enter specific dates, 
select the Selected dates radio buttons, then use the drop-down lists and spin boxes to define the 
dates. 
•  Select update method 
 This is the most difficult part of this process to understand. It is also the most important, because 
it will determine the way in which this wizard changes your data. 
 
You have to select exactly what the wizard must look for, and how it should be corrected. You 
have three possible actions - you can choose one or more of these: 
•  Update if MORE detailed Perinatal Death entries exist than deaths entered with Total Births 
 If the wizard finds a month with a birth weight category where MORE detailed perinatal deaths 
were described than the number entered with the Monthly data, it will update the Monthly data to 
reflect the correct number of deaths. Stillbirths, early and late neonatal deaths are evaluated and 
updated separately. 
•  Update if LESS detailed Perinatal Death entries exist than deaths entered with Total Births 
 If the wizard finds a month with a birth weight category where LESS detailed perinatal deaths 
were described than the number entered with the Monthly data, it will update the Monthly data to 
reflect the correct number of deaths. Stillbirths, early and late neonatal deaths are evaluated and 
updated separately. 
•  Correct birth weight category totals in Total Births to include all detailed Perinatal Death entries 
 If the wizard finds a month with a birth weight category where the TOTAL number of births is 
LESS than the total number of deaths in that category for which detailed data has been entered, it 
will CHANGE the total number of births in the particular weight category to reflect all deaths. 
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Think very carefully before you use this function! You will actually be changing the total number of 
births entered previously, and may actually be entering incorrect data. Are you sure all perinatal 
deaths were entered correctly? Could it be that the date of birth entered for some births may be 
incorrect, not the total number of births entered for a month? ONLY if you have absolute 
confidence in the accuracy of your detailed perinatal death data, and are sure that the mistakes 
were made upon entering or calculating the number of births, should you enable this function. 
•  Ready? 
 A page is displayed to give you a chance to change your settings. Click on the Update button to 
start the process. 
 
Once you have initiated the import process, you cannot cancel it, and you have to wait for it to 
complete before you will have control of the wizard again. 
 
The changes to your existing data files are PERMANENT and cannot be undone! 
•  Applying updates... 
 While the wizard updates your data, you will be informed about its progress. 
•  Done! 
 After the process has been completed, click on the Close button to close the wizard.  
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Print data sheets 
 
PPIP allows you to print pre designed data sheets on which the different data types can be 
collected before entry on the computer. 
 
To print the Monthly data sheets, select Tools -> Print data sheets -> Monthly data sheet 
from the Main menu.  
 
To print the Perinatal death sheets, select Tools -> Print data sheets -> Perinatal death 
data sheet from the Main menu. 
 
To print the Maternal death sheets, select Tools -> Print data sheets -> Maternal death 
data sheet from the Main menu. 
 
You will be prompted to enter the number of copies you want to print, after which the print 
preview will be displayed, ready to print the data sheets.  
 
 

Number of copies 
 
Enter the number of copies of the selected data sheet you want to print, then click on the Print 

button. You will be presented with a print preview before you actually print the list. 
 
Click on the Cancel button to close the window without printing the data sheet.  
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Print code lists 
 
PPIP allows you to print lists containing the codes used by the program. 
 
To print the codes for the Obstetric causes of perinatal death, select Tools -> Print code lists 
-> Obstetric cause of perinatal death from the Main menu.  
 
To print the codes for the Final causes of neonatal death, select Tools -> Print code lists -> 
Final cause of neonatal death from the Main menu. 
 
To print the codes for the Avoidable factors, select Tools -> Print code lists -> Perinatal 
death avoidable factors from the Main menu. 
 
To print the codes for the Obstetric cause of maternal death, select Tools -> Print code lists -
> Obstetric cause of maternal death from the Main menu. 
 
To print the codes for the Final causes of maternal death, select Tools -> Print code lists -> 
Final cause of maternal death from the Main menu. 
 
You will be prompted to enter the number of copies you want to print, after which the print 
preview will be displayed, ready to print the data sheets.  
 
 
Number of copies 
 
Enter the number of copies of the selected code list you want to print, then click on the Print 

button. You will be presented with a print preview before you actually print the list. 
 
Click on the Cancel button to close the window without printing the list.  
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Program settings 
 
PPIP allows you to define certain default settings. These will depend on the way you use the 
program. 
 
To open the Program setup window, select Tools -> Program settings... from the Main 
menu. The default settings are displayed on four tabs: 
 
  
 
Data entry 
 
The following defaults are available: 
•  Data integrity check 
 If you chose to enter perinatal death numbers with your monthly data (discussed here) AND to 
enter detailed perinatal death data, PPIP can use one data entry to check the validity of the other. 

•  If you enter Total births for a month before you enter detail about perinatal deaths for 
the particular month, you can check the Check Perinatal Death entries against Total Births check box. 
When you save a perinatal death, PPIP will now check whether it is reflected correctly in 
your monthly data. (E.g. if your Monthly data for January 2004 shows one stillbirth in the 
500 - 999g category, you will receive a warning if you enter a second stillbirth in this 
weight category delivered during January 2004.) 
   
•  If you enter detail about perinatal deaths for a particular month before you enter Total 
births for the month , you can check the Check Total Births entries against Perinatal Deaths check 
box. When you save monthly data, PPIP will now check whether detailed entries for all 
the perinatal deaths exist. (E.g. if you have entered detailed data about two stillbirths in 
the 500 - 999g category, delivered during January 2004, you will receive a warning if your 
monthly data for January 2004 reflects only one stillbirth in this weight category.) 
   

•  Continuous data entry 
 If you usually enter data for more than one month or death at a time (batch entries), you can 
check the following check boxes to be presented with a new data entry screen as soon as you 
save the current record: 

•  Check the Total monthly data check box to do Monthly data batch entries.  
•  Check the Perinatal deaths check box to do Perinatal death batch entries.  
•  Check the Maternal deaths check box to do Maternal death batch entries. 
  

Click in the Close button after the last entry has been saved. 
 
  
 
Data analysis 
 
The following defaults are available: 
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enter detailed perinatal death data, PPIP can use either of these numbers for some of the data 
analyses. You can select which data should be used by default by selecting one of the following 
radio buttons: 

•  If you prefer to use the number of deaths entered with your Monthly data, select the 
Use data entered with total deliveries radio button. 
   
•  If you prefer to use the number of deaths entered for which detailed data was entered, 
select the Use perinatal deaths for which detailed data was entered check box. 

  
Although you set a default here, the data analysis windows where either data type can be used 
will allow you to select the other method as well. 
 
This default will be ignored on data analysis windows where the particular data analysis can only 
be done if detailed perinatal death data was entered. 
 
Set this default to use the type of data that will always be correct or more up to date in your 
institution. 
 
•  Default data calculation method 
 If you are using a data set with more levels below it in your data pyramid, you can set the default 
data to use for data analysis: 

•  Select the Own data only radio button to use only the currently selected data set's data, 
disregarding the lower levels.  
•  Select the Cumulative data radio button to use the currently selected data set's data as 
well as the data from all lower levels. 
  

Although you set a default here, most data analysis windows will allow you to select the other 
method as well. 
 
If your currently selected data set does not have lower levels below it in the data pyramid, this 
default will obviously be ignored, and all data analyses will be done for the selected data set only. 
 
•  Default data period for time graphs 
 A number of data analyses look at trends over time, and are also presented as graphs where 
time is displayed on the x-axis. You can include data for six months, one year, two years, five 
years or all data in these time graphs. Use the radio buttons to set a default time to include in 
these graphs when the data analysis windows open. 
 
Although you set a default here, all data analysis screens will allow you to change the data 
period. 
 
•  Maternal Mortality Rate denominator 
 Maternal Mortality Rate is defined as Maternal deaths per 100,000 women of reproductive age 
(15 - 49yrs), i.e. 
 
              Maternal deaths          
                                                 x 100,000 
    Women of reproductive age 
 
Use this entry field to enter the number of women of reproductive age in your community, if 
known. 
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If no denominator is set, the maternal mortality rate is not calculated. 
 
•  Perinatal mortality rate 
 The Perinatal Mortality Rate is defined as the number of Fetal deaths and early neonatal deaths 
per 1000 births, i.e. 
 
    Fetal deaths + Early neonatal deaths 
                                                                  x 1,000 
                      Total births 
 
In version 1, PPIP included all deaths in the calculation of its perinatal mortality rate, not only the 
deaths in the perinatal period as defined here. It therefore actually calculated a 'Perinatal related 
Mortality rate'. You can now choose to exclude the late neonatal deaths and adhere strictly to the 
definition as provided above (select the Include only deaths in perinatal period radio button, or to continue 
using all deaths, including late neonatal deaths (select the Include deaths in perinatal and late neonatal period 

radio button). 
 
•  Default number of items in pie graphs 
 A number of data analyses look at lists of items, and are also presented as pie graphs to 
illustrate the relative frequency of specific items. You can include up to ten most frequent items in 
these pie graphs. Use the radio buttons to set a default number of items to include in these 
graphs when the data analysis windows open. 
 
Although you set a default here, all data analysis windows will allow you to change the number of 
items included in the pie graphs. 
 
•  Default grade of avoidable factors to list 
 The Avoidable factors associated with perinatal deaths data analysis window displays a 
list of avoidable factors identified with perinatal deaths. The list can include one or both of the 
avoidable factors grades. Use the radio buttons to set a default grade of avoidable factors to 
include in this list when the data analysis window opens. 
 
Although you set a default here, the data analysis window will allow you to change the grade(s) to 
include. 
 
•  Default denominator: avoidable factors 
 On the Avoidable factors associated with perinatal deaths data analysis window the 
avoidable factors can be displayed as a percentage of all codes (individual avoidable factors) 
identified with perinatal deaths, or as a percentage of perinatal deaths. (Up to five avoidable 
factors can be identified with each perinatal death.) Use the radio buttons to set a default 
denominator to use when the data analysis window opens. 
 
Although you set a default here, the data analysis window will allow you to change the 
denominator. 
 
•  Default denominator: maternal deaths 
 On the Final cause of maternal death data analysis window the causes of death can be 
displayed as a percentage of all codes (individual final causes of death) identified with maternal 
deaths, or as a percentage of maternal deaths. (Up to three contributing final causes of death can 
be identified with each maternal death.) Use the radio buttons to set a default denominator to use 
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when the data analysis window opens. 
 
Although you set a default here, the data analysis window will allow you to change the 
denominator. 
 
•  Close data analysis screens 
 All data analysis windows can be opened from the Data analysis toolbar. You may open all available 
data analysis windows and may close each window separately when you are done. Check the 
Close data analysis windows with toolbar check box to have all data analysis windows close automatically 
when you close the data analysis toolbar. 
 
  
 
Data printouts 
 
Three data analysis windows present you with different groups of data. When you print reports, 
you can include one or more of these groups of data in the printouts. Before the reports are 
created, you will be prompted to select the data to include. You can also make your selections 
permanent defaults, after which all subsequent reports will include only the selected data groups 
without giving you a choice. 
 
This tab allows you to change these default data printout setups. 
 
If you want to be presented with a choice when you print the reports, uncheck the relevant Use this 

default setup check box(es). You can then check or uncheck the parts of the data printouts you want 
to be included or excluded by default. 
 
If you do not want to be presented with a choice when you print the reports, make sure the 
correct parts of the data printout you want included is checked, and then check the relevant Use 

this default setup check box(es). 
 
  
 
Monthly report 
 
This tab allows you to set up a summary of monthly data for easy reporting of basic data. This 
report can be printed. 
 
To define which fields you want to include in the report, use the check boxes to select the data 
fields you want to include in the report. The following data fields can be selected: 
 
•  Table containing total births 
 This will include a summary of total deliveries, early neonatal deaths, late neonatal deaths and 
stillbirths in the report. 
 
•  Number of multiple pregnancies 
 This will include the number of multiple pregnancies and neonates born from multiple 
pregnancies. 
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•  Antenatal care summary 
 Check this to include a summary of antenatal care data. 
•  Born Before Arrival 
 This will include the number of babies born before arrival to the health care institution. 
 
•  Method of delivery summary 
 Check this to include a table of delivery methods. 
 
•  Syphilis serology summary 
 Check this to include a summary of maternal syphilis serology. 
 
•  HIV serology summary 
 This will include a summary of maternal HIV serology. 
 
•  Maternal age summary 
 Check this to report on deliveries by teenagers and women older than 34 years of age. 
 
You must also select the data to be used when reporting on perinatal and neonatal deaths. You 
can either Use data entered with total deliveries, or Use perinatal deaths for which detailed data was entered. See here 
for a discussion of perinatal and neonatal death data entered with monthly data. 
 
 
Optional modules 
 
This tab allows you to set up the use of optional modules. When a module is used, additional data 
entry fields become available, and additional data analyses are possible. 
 
Currently, only one additional module is available: 
 
• Anti-retroviral Therapy module 
 This will activate the module allowing entry and analysis of the use of anti-retroviral therapy. 
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Print preview 
 
Before any report is printed, you will be presented with a preview of the report, from which you 
can cancel the process, or print the report or only part thereof. 
 
View controls 
 
You can view different pages in more or less detail, i.e. 'zoomed' in or out. There are various 
ways to change this: 
•  Click on the Zoom in on a page of the report button. Select the appropriate view from the list of option 
displayed.  
•  Select the appropriate view from the Zoom drop-down list.  
•  Select Zoom on the Main menu, then select the view from the options displayed.  
•  Right-click on a page currently displayed, and select the view from the options displayed.  
•  Left-click on a page currently displayed to alternate between Page width and Tile pages. Page width 

displays a single page with the page width filling the screen, while Tile pages displays one or more 
pages as thumbnails. To arrange these thumbnails, use the Across and Down spin boxes to 
specify the number of pages to be displayed on the screen.  
•  Select View -> Change display from the Main menu. The Change the Report Display 
window allows you to arrange page thumbnails on the screen. 
 
Print the report 
 
To print all pages of the report, click on the Print this report button, or select File -> Print from the 
Main menu. 
 
To print selected pages only, select File -> Pages to print… from the Main menu, enter the 
page number to be printed, and click on the OK button. 
 
Cancel printing 
 
To close the print preview without printing the report, click on the Exit without printing the report button. 
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Registering PPIP 
 
Tell us about yourself 
 
There are two important considerations in the distribution of PPIP. Firstly, it is important to make 
sure that every user is using the latest update of the program and its code lists. Secondly, we 
want to bring together different users of the program with a view to possibly comparing and/or 
combining data for wider analysis.  
 
With this in mind, you will have to register your copy of PPIP with Simply Software. This is NOT 
an attempt to control the use of PPIP, and PPIP will continue to be distributed free of charge on 
the Internet. Furthermore, the limited personal information you supply when registering the 
software will NOT be distributed in any way without your explicit permission. 
 
 
 
What if I don't want to register? 
 
When you initially install PPIP v2 on your computer, you will be granted a demo licence for a 
period of six weeks. During this time you will have access to all the program functions. If you 
have not entered a registration code by the end of this period, you will still be able to enter data, 
but all data analysis functions will be disabled. Reinstallation of the software will not grant you a 
new demo licence. 
 
 
 
How do I register? 
 
You can apply for a user's licence via surface mail or on the Internet. 
 
Select Help -> Register this copy of PPIP from the Main menu. The Register PPIP window 
will open. Select the Apply for registration code tab. You can: 
 
•  Register by surface mail 
 Click on the Register by surface mail button. This will allow you to print a pre designed licence 
application form. Send the completed form via post to Simply Software at the address indicated. 
 
•  Register on the Web 
 Click on the Register on the Web button. This will allow you connect to the correct page on the PPIP 
web site. Complete the application form on the web, which will be sent to Simply Software. 
 
With both application methods you will have to indicate your preferred contact detail. Simply 
Software will contact you with registration licence detail. Once you have received this, open the 
Register PPIP window as described above, and select the Enter registration detail  tab. Now enter the 
registration detail exactly as it was supplied to you. Click on the Register button to complete the 
registration process. 
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Are there any restrictions? 
 
PPIP is licensed per user or institution, whichever is relevant. This means that it can be installed 
and used on more than one computer, and (if licensed to an institution) by more than one user 
without applying for more licenses. 
 
Once the licence code for a copy of PPIP has been entered, it will never lapse. 
 
If a user leaves his / her current institution and starts using a personally licensed copy of PPIP in 
a different institution, we would appreciate a note in that regard - see the first remarks on this 
page.  
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Licensing agreement 
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This is a copy of the complete licensing agreement you agreed to when you installed PPIP v2. 
 
PERINATAL PROBLEM IDENTIFICATION PROGRAM V2 LICENCE AGREEMENT 
 
IMPORTANT - READ CAREFULLY: This end user license agreement (EULA) is a legal 
agreement between you (either an individual or a single entity) and Johan Coetzee ("Simply 
Software") for the Simply Software software product identified above, which includes computer 
software and associated media, and may include printed materials and online or electronic 
documentation ("SOFTWARE PRODUCT" or "SOFTWARE"). By installing, copying, or otherwise 
using the SOFTWARE PRODUCT, you agree to be bound by the terms of this license 
agreement. If you do not agree to the terms of this license agreement, promptly return the unused 
SOFTWARE PRODUCT to the place from which you obtained it, or, if it was downloaded from the 
Internet, permanently remove all files associated with the SOFTWARE PRODUCT from all 
computers you copied it to. 
 
SOFTWARE PRODUCT LICENSE 
 
The SOFTWARE PRODUCT is protected by copyright laws and international copyright treaties, 
as well as other intellectual property laws and treaties. The SOFTWARE PRODUCT is licensed, 
not sold. If the SOFTWARE PRODUCT was distributed free of charge, the copyright is NOT 
transferred, and Johan Coetzee ("Simply Software") remains the exclusive owner. 
 
1. GRANT OF LICENSE. 
This license agreement grants every registered user of the SOFTWARE PRODUCT the following 
rights: 
 
SOFTWARE PRODUCT. If the SOFTWARE PRODUCT is licensed to an individual, this 
individual may install and use the SOFTWARE PRODUCT one or more computer(s), provided 
that the SOFTWARE PRODUCT is used only by this individual. If the SOFTWARE PRODUCT is 
licensed to a single entity or institution, the SOFTWARE PRODUCT may be installed and used by 
representatives of the licensed entity or institution on one or more computer(s), provided that the 
SOFTWARE PRODUCT is used only by representatives of the licensed entity or institution to the 
benefit of the licensed entity or institution. 
 
REFERENCE TO THE SOFTWARE PRODUCT. Data manipulation and analyses done with the 
help of the SOFTWARE PRODUCT may be used for presentation (both oral and as a poster) or 
publication, provided that with any such presentation or publication reference shall be made to 
the SOFTWARE PRODUCT to include the following: "Perinatal Problem Identification Program 
(PPIP) v2 - Developed by Johan Coetzee. Available from www.ppip.co.za" The internet address 
may be omitted if the data is published and the publisher involved does not allow internet 
references to be included in published material. 
 
2. DESCRIPTION OF OTHER RIGHTS AND LIMITATIONS. 
 
LIMITATIONS ON REVERSE ENGINEERING, DECOMPILATION, AND DISASSEMBLY. You 
may not reverse engineer, decompile, or disassemble the SOFTWARE PRODUCT, except and 
only to the extent that such activity is expressly permitted by applicable law  notwithstanding this 
limitation. 
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SEPARATION OF COMPONENTS. The SOFTWARE PRODUCT is licensed as a single product. 
Its component parts may not be separated for use on more than one computer. 
 
RENTAL. You may not rent or lease the SOFTWARE PRODUCT. 
 
SOFTWARE TRANSFER. You may permanently transfer all of your rights under this license 
agreement, provided you retain no copies, you transfer all of the SOFTWARE PRODUCT 
(including all component parts, the media and printed materials, any upgrades and this license 
agreement), and the recipient agrees to the terms of this licence agreement. If the SOFTWARE 
PRODUCT is an upgrade, any transfer must include all prior versions of the SOFTWARE 
PRODUCT. 
 
TERMINATION. Without prejudice to any other rights, Simply Software may terminate this EULA 
if you fail to comply with the terms and conditions of this license agreement. In such event, you 
must destroy all copies of the SOFTWARE PRODUCT and all of its component parts. 
 
DISTRIBUTION OF REGISTERED OR LICENSED VERSIONS OF THE PRODUCT 
PROHIBITED. You may not, for any purpose, distribute copies of registered or licensed versions 
of the software, documentation or related materials to any third-parties. 
 
3. UPGRADES.  
 
If the SOFTWARE PRODUCT is an upgrade from another product, whether from Simply Software 
or another supplier, you may use or transfer the SOFTWARE PRODUCT only in conjunction with 
that upgraded product, unless you destroy the upgraded product. If the SOFTWARE PRODUCT 
is an upgrade of a Simply Software product, you now may use that upgraded product only in 
accordance with this license agreement. 
 
4. COPYRIGHT.  
 
All title and copyrights in and to the SOFTWARE PRODUCT, the accompanying printed materials 
(if any) and online or electronic documentation , and any copies of the SOFTWARE PRODUCT, 
are owned by Simply Software. The SOFTWARE PRODUCT is protected by copyright laws and 
international treaty provisions. 
 
MISCELLANEOUS 
 
GOVERNING LAW.  
 
This license agreement is governed by the laws of the Republic of South Africa. 
 
Should you have any questions concerning this license agreement, or if you desire to contact 
Simply Software for any reason, write to: Simply Software 
PO Box 536, Irene  
0062 South Africa. 
 
LIMITED WARRANTY 
 
LIMITED WARRANTY. Simply Software warrants that the SOFTWARE PRODUCT's associated 
media will be free from defects for a period of six (6) months from the date of receipt. 
 
NO OTHER WARRANTIES. THE SOFTWARE PRODUCT AND THE ACCOMPANYING FILES 
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ARE PROVIDED "AS IS" AND WITHOUT WARRANTIES AS TO PERFORMANCE OF 
MERCHANTABILITY OR ANY OTHER WARRANTIES WHETHER EXPRESSED OR IMPLIED. 
Because of the various hardware and software environments into which the SOFTWARE 
PRODUCT may be put, NO WARRANTY OF FITNESS FOR A PARTICULAR PURPOSE IS 
OFFERED. 
 
Good data processing procedure dictates that any program be thoroughly tested with non-critical 
data before relying on it. The user must assume the entire risk of using the program. ANY 
LIABILITY OF THE SELLER WILL BE LIMITED EXCLUSIVELY TO PRODUCT REPLACEMENT 
OR REFUND OF PURCHASE PRICE. 
 
NO LIABILITY FOR CONSEQUENTIAL DAMAGES. TO THE MAXIMUM EXTENT PERMITTED 
BY APPLICABLE LAW, IN NO EVENT SHALL SIMPLY SOFTWARE OR ITS SUPPLIERS BE 
LIABLE FOR ANY SPECIAL, INCIDENTAL, INDIRECT, OR CONSEQUENTIAL  
DAMAGES WHATSOEVER (INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF 
BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, OR 
ANY OTHER PECUNIARY LOSS) ARISING OUT OF THE USE OF OR INABILITY TO USE THE 
SOFTWARE PRODUCT, EVEN IF SIMPLY SOFTWARE HAS BEEN ADVISED OF THE 
POSSIBILITY  
OF SUCH DAMAGES. 
 
PARTIAL VALIDITY 
 
If any of the above paragraphs is or becomes invalid, this shall not affect the validity of the rest of 
this license agreement.  
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Contact detail 
 
The Perinatal Problem Identification Program v2 has been developed by Johan Coetzee. 
 
Contact me at: 
 
The PPIP web site: 
www.ppip.co.za 
 
Email: 
techsupport@ppip.co.za 
 
Surface mail: 
PO Box 536 
Irene 
0062 
South Africa 
 
 
Financial support (purchasing of software development tools) and the cost of the PPIP web site 
by: 
 
The MRC Research Unit for Maternal and Infant Health Care Strategies 
Private Bag X396 
Pretoria 
0001 
South Africa 
 
Tel and fax: +27 12 373-0825 
Email: matinfru@global.co.za  
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Identifying program functions 
 

Main menu 
 
The Main program menu provides access to some of the program functions. When you left-click 
on a menu item, a further level of functions will drop down. Point the mouse to the correct function 
and left-click. Some of the drop-down menus lead to further menu levels - this is indicated by a 
small arrow to the right. 

 
 
 
 
 
 
 
 
 
 

 
 

Drop-down list 
 
A drop-down list allows the user to select from a set list of choices. Left-click on the list to drop 
down a list of choices, then use the scroll bar to the right if necessary to scroll down the list until 
the correct choice is displayed. Use the mouse to place the pointer on the correct choice then left-
click. The list will close and the selected item will be displayed. 
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Check box 
 
A check box allows the user to select or deselect an option - similar to an on-off switch. If the box 
is checked (selected, marked) it is ' switched on' . If the box is unchecked (not selected, 
unmarked) it is ' switched off' . 
 

    
 

 
Button bar 
 
The button bar provides you with buttons as shortcuts to the most common functions in PPIP. A 
tool tip will appear if you allow the mouse cursor to hover over a button, serving as a reminder of 
the button's function. 
 

 
 
 
  
  
  
  

  
  

Spin box Spin box 
 
The spin box allows two ways to enter numerical data: 
 
The spin box allows two ways to enter numerical data: 
•  With the current value selected, simply type in the new value.  •  With the current value selected, simply type in the new value.  
•  Click on the small arrows to the right of the entry field to increase or decrease the value. 
  
•  Click on the small arrows to the right of the entry field to increase or decrease the value. 
  

 
 

 
 
Tab 
 
Tabs are used extensively to display more on the screen by hiding some fields on different 
'pages'. As would be the case in a filing cabinet, these 'pages' are identified by tabs - clicking on a 
specific tab will bring the particular 'page' into view. The text on the active tab will be displayed in 
red, while the text on all the other tabs is black. 
 
Tabs can be positioned on top or to the right of the 'page' attached to it. 
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Pop-up calendar 
 
PPIP always provides a pop-up calendar when a date has to be entered. The ... button opens the 
calendar. 

 
To select the appropriate month and year, use the scroll buttons 
to the right marked Month and Year to increase or decrease the 
month currently selected. Once the correct month is displayed, 
select the day by left-clicking on it. The date will be transferred 
to the window you were working on, and the calendar will close.  
 
 
 
 
 

 
 
 

Radio buttons 
 
When PPIP allows you to select from a specific set of options, and it wants to display all the 
options, it uses radio buttons. 
 

The options from which you can choose are displayed with empty radio 
buttons to the left. When you left-click on an option to select it, the 
empty button is filled to indicate your choice. Selecting another option 
will de-select the initial option, so that only one option can be selected. 
 

At times PPIP will already select the most commonly used options for you when a window is 
opened. You may obviously change this selection.  
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Definitions 

 
 
Live birth 
 
Live birth is the complete expulsion or extraction from its mother of a product of conception, 
irrespective of the duration of the pregnancy, which, after such separation, breathes or shows any 
other evidence of life, such as beating of the heart, pulsation of the umbilical cord, or definite 
movement of voluntary muscles, whether or not the umbilical cord has been cut or the placenta is 
attached; each product of such a birth is considered live born. 
 
World Health Organization International Statistical Classification of Diseases and Health Problems, Tenth Revision. 1992  
 

 
 
Fetal death (Deadborn fetus) 
 
Fetal death is death prior to the complete expulsion or extraction from its mother of a product of 
conception, irrespective of the duration of pregnancy; the death is indicated by the fact that after 
such separation the fetus does not breathe or show any other evidence of life, such as beating of 
the heart, pulsation of the umbilical cord, or definite movement of voluntary muscles. 
 
World Health Organization International Statistical Classification of Diseases and Health Problems, Tenth Revision. 1992  
 

 
 
Birth weight 
 
The first weight of the fetus or newborn obtained after birth. 
 
For live births, birth weight should preferably be measured within the first hour of life before 
significant postnatal weight loss has occurred. While statistical tabulations include 500g grouping 
for birth weight, weights should not be recorded in those groupings. The actual weight should be 
recorded to the degree of accuracy to which it is measured. 
 
The definition of "low", "very low", and "extremely low" birth weight do not constitute mutually 
exclusive categories. Below the set limits they are all-inclusive and therefore overlap (i.e. "low" 
includes "very low" and "extremely low", while "very low" includes "extremely low". 
 
 World Health Organization International Statistical Classification of Diseases and Health Problems, Tenth Revision. 1992  
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Low birth weight 
 
Birth weight less than 2500g (up to and including 2499g). 
 
 World Health Organization International Statistical Classification of Diseases and Health Problems, Tenth Revision. 1992  
 

 
 
Very low birth weight 
 
Birth weight less than 1500g (up to and including 1499g). 
 
 World Health Organization International Statistical Classification of Diseases and Health Problems, Tenth Revision. 1992  
 

 
 
Extremely low birth weight 
 
Birth weight less than 1000g (up to and including 999g). 
 
 World Health Organization International Statistical Classification of Diseases and Health Problems, Tenth Revision. 1992 
 
 
 
 
Perinatal period 
 
The perinatal period commences at 22 completed weeks (154 days) of gestation (the time when 
birth weight is normally 500g), and ends seven completed days after birth. 
 
World Health Organization International Statistical Classification of Diseases and Health Problems, Tenth Revision. 1992  
 

 
 
Neonatal period 
 
The neonatal period commences at birth and ends 28 completed days after birth. Neonatal 
deaths (deaths among live births during the first 28 completed days of life) may be subdivided 
into early neonatal deaths, occurring during the first seven days of life, and late neonatal deaths, 
occurring after the seventh day but before 28 completed days of life. 
 
World Health Organization International Statistical Classification of Diseases and Health Problems, Tenth Revision. 1992  
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Fetal death ratio 
 
Fetal deaths per 1000 live births, i.e. 
 
    Fetal deaths 
                          x 1000 
     Live births 
 
World Health Organization International Statistical Classification of Diseases and Health Problems, Tenth Revision. 1992  
 

 
 
Fetal death rate 
 
Fetal deaths per 1000 births, i.e. 
 
    Fetal deaths 
                          x 1000 
     Total births 
 
World Health Organization International Statistical Classification of Diseases and Health Problems, Tenth Revision. 1992  
 

 
 
Early neonatal mortality rate 
 
Early neonatal deaths per 1000 live births, i.e. 
 
    Early neonatal deaths 
                                         x 1000 
         Total live births 
 
World Health Organization International Statistical Classification of Diseases and Health Problems, Tenth Revision. 1992  
 

 
 
Perinatal mortality rate 
 
Fetal deaths and early neonatal deaths per 1000 births, i.e. 
 
    Fetal deaths + Early neonatal deaths 
                                                                 x 1000 
                      Total births 
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World Health Organization International Statistical Classification of Diseases and Health Problems, Tenth Revision. 1992 
 
In version 1, PPIP included all deaths in the calculation of its perinatal mortality rate, not only the 
deaths in the perinatal period as defined here. It therefore actually calculated a 'Perinatal related 
Mortality rate'. You can now choose to continue using all deaths (including late neonatal deaths), 
or you can exclude the late neonatal deaths and adhere strictly to the definition as provided 
above. 
 
See program setup for information on how to choose the deaths to include.  
 

 
 
Neonatal mortality rate 
 
Neonatal deaths per 1000 live births, i.e. 
 
    Neonatal deaths 
                                x 1000 
     Total live births 
 
World Health Organization International Statistical Classification of Diseases and Health Problems, Tenth Revision. 1992  
 

 
 
Maternal death 
 
A maternal death is the death of a woman while pregnant or within 42 days of termination of 
pregnancy, irrespective of the duration and site of the pregnancy, from any cause related to or 
aggravated by pregnancy or its management, but not from accidental or incidental causes. 
 
World Health Organization International Statistical Classification of Diseases and Health Problems, Tenth Revision. 1992  
 

 
 
Maternal mortality rate 
 
Maternal deaths per 100,000 women of reproductive age (15 - 49yrs), i.e. 
 
           Maternal deaths 
                                                   x 100,000 
    Women of reproductive age  
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Maternal mortality ratio 
 
The World Health Organization states: 
"The denominator used for calculating maternal mortality should be specified as either the 
number of live births or the number of total births (live births plus fetal deaths). Where both 
denominators are available, a calculation should be published for each."  International Statistical 
Classification of Diseases and Health Problems, Tenth Revision. 1992 
 
Therefore, PPIP calculates two maternal mortality ratios using these denominators: 
 
Maternal deaths per 100,000 births, i.e. 
 
    Maternal deaths 
                                 x 100,000 
        Total births 
 
 
             AND 
 
 
Maternal deaths per 100,000 live births, i.e. 
 
    Maternal deaths 
                                x 100,000 
    Total live births  
 
 

 
Perinatal Care Index 
 
This index reflects perinatal mortality rate seen against the low birth weigh rate, i.e. 
 
  Perinatal mortality rate (Birth weight >999g) 
                                                                         
        % Low birth weight infants delivered  
 

 
 
3-month moving average 
 
A moving average is often used in graphs to smooth out the graph line in order to make it easier 
to see trends. PPIP uses a three-month moving average, which means a point on the graph is 
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always the average (mean) of the actual value for the current month and the two preceding 
months.  
 

Obstetric cause of perinatal death 
 
The primary obstetric cause of perinatal death refers to the particular obstetric condition or 
pathology that initiated the chain of events eventually leading to the baby's death. PPIP is 
distributed with a list of causes, each with a code which identifies the cause. You are not allowed 
to make any changes to this list of causes - this would eventually lead to chaos, as slowly each 
unit would develop its own code list, making data analysis in a data pyramid impossible.  
 
 

 
Final cause of neonatal death 
 
The final cause of neonatal death refers to the eventual pathology that claims the baby's life. 
PPIP is distributed with a list of causes, each with a code which identifies the cause. You are not 
allowed to make any changes to this list of causes - this would eventually lead to chaos, as slowly 
each unit would develop its own code list, making data analysis in a data pyramid impossible.  
 
 

 
Obstetric cause of maternal death 
 
The primary obstetric cause of maternal death refers to the particular obstetric condition or 
pathology that initiated the chain of events eventually leading to the woman's death. PPIP is 
distributed with a list of causes, each with a code which identifies the cause. You are not allowed 
to make any changes to this list of causes - this would eventually lead to chaos, as slowly each 
unit would develop its own code list, making data analysis in a data pyramid impossible.  
 

 
Final cause of maternal death 
 
The final or contributing cause of maternal death refers to the eventual pathology that claims the 
woman's life. PPIP is distributed with a list of causes, each with a code which identifies the cause. 
You are not allowed to make any changes to this list of causes - this would eventually lead to 
chaos, as slowly each unit would develop its own code list, making data analysis in a data 
pyramid impossible.  
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